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Files to use 

The downloaded data folder contains the following files 

 

 

 

 

 

・Controller.3dm 

The first Rhinoceros 4.0 file to use. 

・Hayabusalogo_01.tga 

An image file to use as a material. 

・quickstart_01 - 05.hyp2 

A creating process file of Hayabusa 2.0 

This is used when you want to start using in the 
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*Hayabusa Renderer 2.0 for Rhinoceros here in after may be referred to as Hayabusa 2.0 or Hayabusa. 

Rhinoceros 4.0hereinafter may be referred to as Rhino4.0 or Rhino. 

 

●Export from Rhinoceros 4.0 
1. To start, double click the Rhinoceros 4.0icon on Desktop. 

2. In the Startup Template dialog, select "Large Objects - Millimeters" and click Open  

 

 

3. Select Menu > File > Open, then select controller.3dm to open. 
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4. When you right click the Hayabusa icon in the top-right of the screen, the Output setting dialog opens. Here, you can 

setup various things. Set up as illustrated below, then click the OK button to close the setup screen. 

 

Material type: 

Rhino material is transferred as RGB value to Hayabusa 

2.0.If you set it on a layer, the layer color will be exported 

as a material so you can set up a quality level for each 

layer. 

 

Object type： 

Select either Polygon or NURBS. If you export it as 

NURBS, you can edit it later in Rhino when the model is 

changed, but Polygon is easier to handle. This time, 

select Polygon. 

 

Hayabusa 2.0Mode： 

Hayabusa 2.0, select HDR. You can display a HDR 

image as a background. 

 

5. Click the OK button to close and left click the Hayabusa icon on the Rhino 4.0 screen to start Hayabusa 2.0. When 

you select Polygon as an Object type in the Output setting, the Polygon mesh options dialog appears. This time, 

move the slide bar one notch to the More Polygon direction and click OK. 

 

 

When you click the 

Preview button, you can 

verify the current 
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■Option 
In Detailed Controls, you can set up how to divide the polygon like distributing more polygons to the area where 

the angle is steeper. 

 

 
 

   
 Default                    Mesh example after setting options above 

 

●Start Hayabusa 2.0 
6. When Hayabusa 2.0 starts, the model exported will be displayed. 

 

■Option 
When Hayabusa is started automatically from the modeler, the model is opened as a temporary file until once you 

save it. (You cannot change the name and the location of the temporary file.) When you close Hayabusa, select File 

> Save Project and save the file using Hayabusa’s file extension.hyp2. 

■quickstart_01.hyp2 

 

 

 

Maximum angle: 

A smaller value will result 

more polygon, but will be 

more accurate. 

Minimum edge/Maximum 

edge: 

These are the maximum and 

minimum edge lengths of the 

subdivided face.  You can 

set up the curve precisely 

using the maximum and 

minimum edge lengths. For 

example, a shorter minimum 

edge length will define a 

tight curve. 
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7. When you click the + sign next to "root" in the Scene graph window on the left, you can see that the layer info set in 

Rhino 4.0 was imported as it was. 

 

●Option 
The window can be moved by dragging the upper gray title bar. 

The docking guide appears when you drag a window to the top, bottom, right or left side of the screen. When you 

drop a window on to the Docking guide, the window is docked to the side. Also, you can dock it by double clicking. 

 

Notes：If the drawing is broken or you cannot redraw it after exporting from Rhino to Hayabusa, most likely the version of 

your video card's driver is old. Update your video card's driver. 

 

●View operation ・Setup camera 
8. Let's play with the model in the viewport. Here's how to use a mouse. 

Ctrl+Right click: Rotate camera 

Shift+Right click: Move camera 

Alt+Right click or wheel mouse: Zoom camera 

To select an object, double click it.  Then by holding Ctrl+G, the object will be zoomed fully. 

9. Add a camera. With the angle you want, select the Default scene graph camera in the Camera tab and click the 

Copy button. A new angled camera is added. Select the name and change it to "camera02".A camera will be added 

Docking Guide 
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to the presentation window in the bottom of the screen as well. 

    

When you check camera02, the camera is switched to it. 

  

*Another way to do it is to create and select a new camera first, then change the angle to one you like,  right click in 

the screen and select Save current view (F5) option to save the camera change. 

 

Other than using the mouse, you can switch the fixed cameras by clicking the icon in the Presentation window（Ctrl+P）

in the bottom of the screen. 

 Default camera 

 

[-Z 270] 

  

[+X 180] 

 

[+Y] 

●Setup floor 
10. Looking at the model from the side (-Z 270), you can see the camera is partially buried in the floor. 
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As a default, Hayabusa 2.0 displays the floor as Rhino model's original floor plane. 

 

  Wireframe display 

                     

11. Highlight and select the default background in the Background list in the Background tab. Then click the Automatic 

button which is located to the right of Floor Height box. This will adjust the floor automatically so the floor does 

not bury the model. Also, you can set the value high/low by typing a number. The reflection on the floor can be 

adjusted as well here. 

    
 

 

 

 

●Setup lighting 
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12. Switch to camera02. 

To turn the light on, switch to the Light tab and select Default scene graph light. 

 
If you drag the active light with Ctrl+left mouse button, you can change the direction of the light as you like. 

  

Also, the darkness of shadows and soft shadows can be adjusted. 

 

 

It is helpful to display the guide to see the direction of the light source that you are adjusting. To display the light 

guide, select the menu Show  > Light Guide. Turn the light guide ON/OFF with Alt+L. 

 

 

Also, directly clicking and 

dragging the guide can be used 

to adjust the light source. 

 

 

 

 

 

 

 

Rotate tool 

■quickstart_02.hyp2 

13. Import a background scene from the library. Select the Library button from the toolbar to open the library. 
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Switch to the Background tab and drag Multishadow-01.hbg2 to the scene. 

 

14. Adding the background scene library, four types of light sets are added to the Background tab. Check [Light-set-01] 

to switch. 

  

 
15. As the background scene was imported with the floor, readjust the height of the floor with the Automatic button. 
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16. Select Automatic for the size in the Background property. Hayabusa automatically adjust the size of the background 

according to the size of the object. 

 

 →    

Image shown the background by zooming the camera out 

●Option 
The background scene includes various settings such as light, background image and floor. 

If you open the Light tab, you can see that several lights with soft lighting expressions are added. Switch 

background environments and see how these lights are utilized. 

 

 
Light-Set-01 

 
Light-Set-02 

 
■quickstart_03.hyp2 

●Setup material 
17. To make sure the "Use High Quality renderer shader" is selected as a rendering mode, select the menu Window > 
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Environment setup. 

 

■Select/Deselect object 

18. Double click the Body in the viewport to highlight it in yellow. Or, you can select it by clicking [body] in the Scene 

graph on the left side of the screen. To release the selection to see its quality, press Esc key. 

  

*In the Scene graph, layers are displayed in hierarchy with "root" in the Top. There is an object info for each surface 

under a layer name. 

■Change the current material 

19. When you switch to the Material tab (with the body object selected), the body material is highlighted which was 

assigned automatically to the layer from the modeler. 

 
20. In the Name&Type pane, change the Type to Metallic. 
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21. In the Color setting pane, set it up as illustrated below. 

 

22. Set it up in the Material type parameters detail pane as illustrated below. 

 
 

■Material types in Hayabusa 2.0 

Lambert  Best for simulating materials which do not reflect light like rubber. 

This only uses diffuse reflection based on the reflection rule that incoming lights diffuse evenly in 

all directions. 

Phong     Best for simulating plastic. This diffuses components and mirror components separately for light 

ray, sight line and normal vector. 

Blinn    Best for simulating metal. This calculates diffuse light and reflection light components in relation to 

diffusion and direction of the model in addition to light rays, sight lines and normal vectors. 

Clearcoat  This simulates clearcoat. The surrounding environment is reflected. 

Glass        Best for simulating glass or transparent plastic. Do the semi transparent process and the 

environment reflection process as well. 

Metallic   Best for simulating metallic paint. This shows fine particles and reflects the surrounding 

environment. 
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■Apply a material from library 

23. Also, instead of creating a new material, you can apply an existing material from the library. Select Window > Library 

to open the Material library. 

Select [clearcort.hmt2] from the Library file name, highlight [CCBlack] and drag & drop it to the [base] object in the 

viewport. 

 

 
24. When you open the material list, you can see the [CCBlack] that you applied is added. You can also see the [base] 

material that had been applied is now grayed out because it is no longer used. 
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Change the name of the base material from  [CCBlack] to [base_2]. 

 

25. Change the Color setting like the image below. 

  
 

26. In the same way, apply the material from the library listed below to [center_button] in the center and [ move_button] 

(the cross key). 

Change the material names to [center_button_2]and[move_button_2]. 

●center_button 

SampleMaterial.hmt2 [metallic_04_gold] 

  

●move_button 

Plastic.hmt2 [PLSilver] 
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■Drag & drop to layer 

27. Then apply the material from the library listed below to [controller]. 

Even if you drag them only to the parts on the left hand side, same materials are applied in both right and left sides, 

since it is the same layer. 

Change the name of the material to [controller_2] and set the diffuse reflection color as you like. 

●controller 

SampleMaterial.hmt2 [shibo_02_gray] 

 

 

 

 

  

 

28. For the LR button, apply [RBSliver] material from the [rubber] library. If you apply it by dragging and dropping, all 

four buttons are updated, because they use the same layer. 
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29. Select the upper two buttons by double clicking and holding the Shift key. In the same way from the library, select 

and right click [RBBlack] and select the Apply to Scene from the context menu. This allows you to apply an individual 

material to objects on the same layer. 

  

Then, change material names from [ RBSilver] to [LR_down], from [RBBlack] to [LR_up]. 

 

*When you do not apply a material from the library, you can select a material that you like from the Material list or 

create a new material and click the Apply button. 

 

 

■Copy & paste a material with Eyedropper 

30. Select [A_button] from the Material list. To make it a plastic material, switch the type to Phong. 
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31. Also, change the other settings as illustrated below to make a gloss highlight for the plastic material. 

 

 

32. Double click the object A_button to select it, and zoom into the object by using Ctrl+G. If you deselect it by pressing 

Esc key, you can see the highlight is set. 

 

33. If you want to copy these plastic attributes to the another button and apply [A_button] material to the another object 

as it is, the diffuse color will be also copied. 

34. Then use the Register Eye dropper. Select and right click A_button in the view, then select Register Eye dropper 

from the context menu. Uncheck the Diffuse color from the opened window, and click the Register button. 



18 
 

  
 

35. Select and right click [B_button] in the same way and select Apply Eye dropper from the context menu, then apply 

it in the opened window. 

  

36. In the same way, apply Eye dropper to all buttons. The status of the highlight is copied. 



19 
 

 

■quickstart_04.hyp2 

■Apply logo texture 

37. Apply a logo to Body. Select [body] in the Material list, and click None in the Texture in the Mapping pane. 

 
 

 

 

38. In the opened Mapping window, select Image setting > Image, and specify "Hayabusalogo_01.tga" from the file. 

 

Hayabusalogo_01.tga. 

 

Color images 

 

Alpha channel 
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39. To adjust the position and size of the image, select Mapping > Adjust > Show Guide . 

Since the direction is different, switch the Direction of Axis to Z. 

  

 

 

 

 

 

40. Set the size Relative W 0.3 H 0.3. Deselect the Repeat check box. 

  

41. Switch the camera to the Fixed Camera-Z. Since the logo is flipped, select Image setting > U 
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Reverse.   

 

 
42. Adjust the position and size of the image again. Select Adjust > Move, drag the shown handles to adjust the height 

and the position. 

Also, switch the size to Absolute to change it to W 36.000/H 12.000 (same as the aspect ratio of the image). 

  

43. Finally switch the Operation for each map category to Decal.  Multiplication superimposes the RGB of the texture 

image on the base color, but if you choose Decal, you can paste the logo, based on the alpha channel that the image 

had. 

  

■quickstart_05.hyp 
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●Switch to Real time ray tracing [ Ctrl+ F3 ] 
44. Switch to camera02. Select the menu Window > Environment setup, change the rendering mode from the High 

Quality Renderer to the Real time ray tracing. 

  
 

The main difference between the Standard renderer and the High Quality Renderer or the Real time ray tracing 

that you can simulate more accurate reflection and refraction because the High Quality renderer and the 

Real time ray tracing perform the reflection and refraction several times. 

In this case, you can see the reflection against the body or base object that shows the surrounding objects (the 

controller and the button, etc.) and not just the environment. 

  

●Option 
Ray tracing is a rendering method that casts a sight line from the view point to every pixel of the display and 

renders in relation to light reflection and transparency on 3D models. It can represent objects realistically as it 

traces light paths emitted from a light source accurately according to reflections, refractions or transparency. 

However, since the calculation amount is enormous, it usually needs a very long time for the calculation. 

 

Hayabusa 2.0 uses your computer's GPU（Graphics Processing Unit: a semiconductor chip for 3D drawing 

equipped on a video card), not your computer's CPU, to perform the real time ray tracing. 

It is handy to use the shortcut for 

switching rendering modes. 

 

Ctrl+F1 --> Standard Renderer 

Ctrl+F2 --> Advanced Renderer 

Ctrl+ F3 Real time ray tracing 
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Without real time ray tracing            With real time ray tracing 

 

●Export images 
45. You can export a rendered image set in Hayabusa 2.0 as a still image or create an animation from it. Select 

Function > Create Image 

 
 

46. Not only still images (snapshots) but also registered snaps of several camera images and fixed cameras can be 

exported in the Export Images window. You can export an animation here too. It is possible to export in higher 

resolution than the display resolution. You can set up to12000 x 12000pixel. (Depending on the video card, there 

may be a limit to the resolution size.) 

 

This time, set 64 for the Jittering Quality,800 x 600 for the pixel size and 300 dpi for the resolution, then click the Start 

button. Then, save the image file with a name of your choice. 

 

＊Jittering quality 

Hayabusa 2.0 superimposes CG more than once by displacing a viewpoint position little by little randomly to make 

the curves less jaggy (Jittering). Here, you can specify how many times to repeat the jittering process. 
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-END- 


