
1 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hayabusa Renderer 2.0 
for Rhino 

Operation Guide 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

GRAPS Co.,Ltd. 
〒150-0031 BEVERLY HILLS 203 Sakuragaoka-tyo Shibuya-ku Tokyo Japan 

 
All documents, graphics and charts in this book and Hayabusa are the copyright of GRAPS Co.,Ltd. 

It is prohibited to reproduce, copy or reprint it without permission. 
Copyright © 2010 GRAPS Co.,Ltd. 



Hayabusa 20 Operation Guide 

2 

 

Contents 

1 Getting started   ...................................................................................... 5
1.1 Main features   ..................................................................................................................................................... 6
1.2 System requirements   ........................................................................................................................................ 9
1.3 Renderer   .......................................................................................................................................................... 10

2 Installation   .......................................................................................... 11
2.1 Install Hayabusa   .............................................................................................................................................. 11
2.2 Software Structure   .......................................................................................................................................... 12

2.2.1 Hayabusa 2.0 Folder   ....................................................................................................................................................................... 12

2.2.2 Rhino 4.0 Plugin folder   .................................................................................................................................................................. 12

2.2.3 Rhino Menu   ....................................................................................................................................................................................... 13

2.2.4 Troubleshooting   ............................................................................................................................................................................... 13

2.3 Set license   ....................................................................................................................................................... 15
2.4 Apply for license   ............................................................................................................................................. 16

3 Basic operation   .................................................................................. 17
3.1 Start Hayabusa 2.0   .......................................................................................................................................... 17

3.1.1 Start fromHayabusaModeler(Rhinoceros 4.0)   ...................................................................................................................... 17

3.1.2 Parameter settings   ......................................................................................................................................................................... 18

3.1.3 From Start menu   ............................................................................................................................................................................. 18

3.1.4 From Desktop short cut   ............................................................................................................................................................... 18

3.1.5 From Quick Start toolbar   ............................................................................................................................................................. 18

3.2 Exit   ................................................................................................................................................................... 19
3.3 System checker   ............................................................................................................................................... 19
3.4 Window/Tab Operation   ................................................................................................................................... 20
3.5 Mouse operation   ............................................................................................................................................. 21
3.6 Assign function to key   .................................................................................................................................... 24
3.7 Customize operations   ..................................................................................................................................... 25

4 Environment setup   ............................................................................. 28
4.1 Rendering quality   ............................................................................................................................................ 28
4.2 Real time ray tracing   ....................................................................................................................................... 29
4.3 Material Setup   .................................................................................................................................................. 30
4.4 Show   ................................................................................................................................................................ 30
4.5 Coordinate   ....................................................................................................................................................... 30
4.6 View mode   ....................................................................................................................................................... 31
4.7 Library   .............................................................................................................................................................. 31
4.8 Conversion window   ........................................................................................................................................ 31
4.9 3D Device   ......................................................................................................................................................... 32

5 Import/Save files   ................................................................................ 33
5.1 Import Rhinoceros data   .................................................................................................................................. 33

Export from Rhinoceros   .............................................................................................................................................................................. 33

5.2 Import project data   .......................................................................................................................................... 34
5.3 Open Model   ...................................................................................................................................................... 35

5.3.1 Add   ....................................................................................................................................................................................................... 35

5.3.2 omparison model   ............................................................................................................................................................................. 35



Hayabusa 20 Operation Guide 

3 

5.4 Open Hayabusa 1.0 project   ............................................................................................................................ 35
5.5 Save data   ......................................................................................................................................................... 36
5.6 File output   ........................................................................................................................................................ 36
5.7 Import file   ......................................................................................................................................................... 36

6 Setup   ................................................................................................... 37
6.1 Setup procedure   .............................................................................................................................................. 37
6.2 Scene graph   ..................................................................................................................................................... 38
6.3 Set up project   .................................................................................................................................................. 39
6.4 Set up object   .................................................................................................................................................... 40
6.5 Move/Rotate/Scale operation   ......................................................................................................................... 41
6.6 Material Setup   .................................................................................................................................................. 42

6.6.1 Setup in Material tab   ..................................................................................................................................................................... 42

6.6.2 Setup in Material library   ............................................................................................................................................................... 45

6.6.3 Eyedropper function   ....................................................................................................................................................................... 46

6.7 Setup texture   ................................................................................................................................................... 47
6.7.1 Texture Mapping   .............................................................................................................................................................................. 47

6.7.2 Bump Mapping   .................................................................................................................................................................................. 48

6.7.3 Specular Mapping   ............................................................................................................................................................................ 48

6.7.4 Customize Environment mapping   .............................................................................................................................................. 48

6.8 Camera setup   .................................................................................................................................................. 49
6.9 Setup light   ........................................................................................................................................................ 50
6.10 Set background scene   .................................................................................................................................... 52

6.10.1 Setup in Background tab   .............................................................................................................................................................. 52

6.10.2 Setup in Backgrond library   .......................................................................................................................................................... 54

6.11 Animation setup   .............................................................................................................................................. 55

7 Variation   .............................................................................................. 57
7.1 Setup material variation  .................................................................................................................................. 57
7.2 Setup parts variation   ....................................................................................................................................... 58

8 Reload   ................................................................................................. 59

9 Presentation   ....................................................................................... 60
9.1 Switch camera   ................................................................................................................................................. 60
9.2 Switch material   ................................................................................................................................................ 60
9.3 Switch part   ....................................................................................................................................................... 60
9.4 Switch background   ......................................................................................................................................... 60
9.5 Play animation   ................................................................................................................................................. 61
9.6 Play rotational motion   ..................................................................................................................................... 61
9.7 Show Comparison   ........................................................................................................................................... 61

10 Create Image   ....................................................................................... 62
10.1 Snapshot   .......................................................................................................................................................... 62
10.2 Camera at once   ............................................................................................................................................... 63
10.3 Fixed Camera   ................................................................................................................................................... 63
10.4 Turntable   .......................................................................................................................................................... 64
10.5 Camera Motion   ................................................................................................................................................ 65
10.6 Animation  ......................................................................................................................................................... 65

11 HDR Rendering   ................................................................................... 66



Hayabusa 20 Operation Guide 

4 

11.1 Switch to HDR mode   ....................................................................................................................................... 66
11.2 Processing in HDR/IBL mode   ......................................................................................................................... 66

12 Real time ray tracing   .......................................................................... 67
12.1 Switch to Real time ray tracing mode   ........................................................................................................... 67
12.2 Limitations   ....................................................................................................................................................... 68

13 Automatic adjustment/ Tone mapping   .............................................. 69
13.1 Auto-exposure   ................................................................................................................................................. 69
13.2 Tone mapping   .................................................................................................................................................. 69

14 Other functions   .................................................................................. 70
14.1 Show absolute size   ......................................................................................................................................... 70
14.2 Move scene to center   ...................................................................................................................................... 70
14.3 Fit to selected object   ...................................................................................................................................... 70
14.4 Camera matching   ............................................................................................................................................ 71

14.4.1 Create camera matching image   ................................................................................................................................................. 71

14.4.2 Camera lens and Perpendicular view angle   ........................................................................................................................... 72

14.5 Solar position calculation  ............................................................................................................................... 73

15 Contact   ................................................................................................ 74
 
 
 
 



5 

 

1 Getting started 
 

Hayabusa Renderer 2.0 for Rhino （hereafter it will be called Hayabusa Renderer 2.0 for Rhino or Hayabusa 2.0) is a "Real 

time renderer" which creates realistic 3DCG images from data you modeled with Rhino. 

It reduces mockup creation on reviewing designs or presentation for customers and helps to save design lead time and costs.  

 

Hayabusa Renderer 2.0 for Rhino enhanced its rendering function significantly by supporting multiple shadows, speeding up real 

time tracing and providing Offline renderer (optional function) which allows you to have global illumination. For animation, you can 

now set up with key frame for object motions and camera motions, and to change colors, parts and background.  

 

We have been developing the product to make it as easy as possible to use, but please read this user guide carefully before 

starting to use it. 

 

If you have any questions, please contact a local reseller, or contact the following phone number or E-mail address. 

Also if you get any problems or opinions while using it, please let us know. 

We will consider your opinions for future development to make it more productive for you. 

 

 

 

Developed by 

GRAPS Co.,Ltd. 

 

〒150-0031 BEVERLY HILLS 203 Sakuragaoka-tyo Shibuya-ku Tokyo Japan 

 

Business hours：10：00～17：00 

 

TEL 03-5456-2680 FAX 03-5456-2681 

E-mail Hayabusa@graps.co.jp 

English language e-mail support is provided. However, telephone support is only in Japanese. 

 

 

mailto:Hayabusa@graps.co.jp�
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1.1 Main features 
Hayabusa 2.0Main features 

 

Renderer 

Rendering Select one from these 3 rendering modes 

･Standard rendering 

･Advanced rendering 

・Real time ray tracing 

HDR/IBL: Select one from these 3 modes 

･No HDR/IBL 

･HDR/IBL（without Bloom effect） 

･HDR/IBL（with Bloom effect） 

Rendering mode on starting (HDR/LDR)Switchable 

Global illumination rendering enabled by 3DsmartRender (Option： Offline 

path tracer) 

File 

Import/Save Import/Save hyp2 file 

Import Hyp file（Hayabusa 1.0 Project) 

Import/Save Polygon, NURBS, Polygon&NURBS data 

Specify NURBS divided parameter 

Specify Unit, coordinate system 

Reload function Material/Camera/Light/Background Auto-setting when re-exporting data to 

Hayabusa after editing in Rhinoceros 

Edit 

Camera Switch camera 

Set position, orientation and target point by bird's eye camera 

Select projection method (perspective/parallel ) 

Specify view angle (Vertical view angle/ Parallel view angle 

Import/Export Camera file(hcm2) 

You can use 3D mouse （3D Connexion products） to control the camera 

Light Light amount Up to 80 

Specify light type (Parallel light/ Point light/ Spotlight)  

Set light source color 

Set attenuation for Point light and Spotlight 

Set orientation and expansion of spotlight 

Set position and orientation by bird's eye light 

Set Ambient 

Set minus light 

Create shadow for parallel light and spotlight （up to 24） 

Specify self-shadow 

Specify shadow darkness and soft shadow 

Turn light on/off 

Import/Export light file (hlt2) 

Material Material 

(Lambert/Phong/Blinn/Clear coat/Glass/Metallic) 

Set Self Luminance 

lighting calculation from back ground image - IBL 

Metallic display method (Standard/Classic) 

HDRI/IBL Set Bloom 

Set Star 

Set exposure 

Set gamma 

Set Diffuse Environment light 
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Mapping Mapping （Texture/Bump/Specular/Environment Mapping 

Projection （Plane/Sphere/Cylinder/Triplanar UV） 

Operation Setting (Multiplication/Decal/Stencil) 

Specify absolute Scale 

Repeat setting 

Specify Mapping direction (XYZ) and Reverse with Button 

Set Mapping with Posture 

Set Mapping display (position, rotation) with Number or Slider 

Display Handler (Frame) 

Display Mapping images as Thumbnail 

Edit 

Background Scene Import background image 

Switch background 

Background image display type （Sphere/Cube/Dome) 

Background image type (Cube/Spherical/Light probe) 

Change Floor Texture 

Specify background color to display it in single color  

Floor reflection 

Set Floor roughness 

Specify floor color to display it in single color  

Specify background size. 

Import/Export background file (hbg2) 

Object NURBS Polygon Subdivision 

(Tolerance, Topology ON/OFF, Topology Tolerance) 

Display/Create shadow/Dropped Shadow per Object or Group 

Animation Turntable motion 

Camera Motion 

Object Motion 

Change Material/Part/Background 

Move/Rotate Move/Rotate/Scale with Posture 

Move/Rotate/Scale with Conversion panel 

Global coordinate/Local coordinate 

Absolute/Offset 

Variation Change color by registering target object or color to change 

Change part, Show ON/OFF 

Scene graph Display Scene graph tree 

Edit model group, Edit tree structure by drag & drop 

Remove group or object 

List materials 

Action History Display Action History window 

Restore action by double click 

Show 
Show Show absolute size function 

Wireframe display 

Hardware Anti-aliasing 

Anti-aliasing (without motion) 

Display info 

Display Light Guide 

Display Camera Guide 

Display Shadow 

Set Auto-Exposure 

Tone Mapping 
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Library 

Material library Display Material in material library data file as thumbnail 

Apply material by drag & drop thumbnail 

Background library Import background by drag & drop  

Tools 

Camera matching Camera matching calculation by specifying rectangle in still image with point. 

Focus on object Fit camera to selected object 

Dropper function Register/Apply material dropper 

Copy object Copy selected object 

Export material 

Still image Export Fixed camera at once  

Export Snapshot 

Export registered camera snap 

Export embedded Opacity （png, tif） 

Movie Export Animation movie  

Export Turntable animation 

Export camera motion movie 

Others 

UI Customize operation (keyboard) 

Customize move/rotate/enlarge camera (mouse) 

Environment setup Undo, Redo 

Rendering quality/Real time ray tracing/Set 

material/Display/Coordinate/View mode/Library/Conversion window/3D 

Device 
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1.2 System requirements 
 

Hayabusa Renderer 2.0 for Rhino System Requirements 

 Standard Renderer High Quality Renderer Ray tracing 

Supported OS Microsoft Windows 2000/XP/Vista 

（Does not work on Windows95/98/98SE/Me/NT） 

CPU Minimum: Pentium Ⅳ 2.0GHz or higher 

Recommended: Dual core or higher 

Memory 2GB or higher recommended 

Web Browser Internet Explorer Ver 6 or later 

Video card 

 

 

 

 

 

 

 

 

 

 

<Minimum system requirements> 

DirectX9.0c VRAM32MB or 

higher 

NVIDIA Geforce2 

ATI Radeon7500/8500 or higher 

 

For onboard video chip 

Intel 845 G or later 

 

Latest driver recommended 

<Minimum system requirements> 

Supports DirectX 9.0c Shader2  

NVIDIA Geforce FX 5900 

ATI Radeon 9800 or higher 

 

<Recommended system requiremen

ts> 

Supports DirectX 9.0c Shader3 

Geforce 6800, FX 3400 or higher 

recommended 

■Activate HDR Mode 

Video memory 256MB or more 

recommended 

 

Latest driver recommended 

<Minimum system requirements> 

Supports DirectX 9.0c Shader3 

Geforce 8800 or higher  

Video memory 512MB or more 

 

Latest driver recommended 

Network 1000 BASE/T recommended 

Mouse 3 button mouse (wheel available） 
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1.3 Renderer 
 

Haybusa Renderer 2.0 for Rhino can work with three types of real time rendering engine; High Quality renderer, Standard 

renderer and Real time ray tracing. Standard renderer can work on low-end PC, but High Quality renderer and Real time ray 

tracing need a video card above a certain performance level to work.  

For System requirements for each renderer, please refer to the previous section "1.2 System requirements". 

 

Functional comparison 

Item Standard 

Renderer 

Advanced 

Renderer 

Ray 

Tracing 

Note 

Shader type Vertex 

Shader(*1) 

Pixel shader Pixel shader 

+ Ray tracing 

*1: Works on CPU 

Shadow Create × ○ ○  

Self shadow × ○ ○  

Material Lambert ○ ○ ○  

Phong ○ ○ ○  

Blinn × 

（*2） 

○ ○ *2: Treated as Phong 

Glass ○ ○ ○  

Clear coat △ 

（*3） 

○ ○ *3: Phong base 

Metallic × 

（*4） 

○ ○ *4: Flake display not available 

 

Mapping Texture ○ ○ ○  

Bump × ○ ○  

Specular × ○ ○  

Reflection ○ ○ ○  

Decal △ 

（*5） 

○ ○ *5: No lighting influence on Decal 

texture  

Stencil △ 

（*6） 

○ ○ *6: Combination of glass material 

and decal or stencil is not 

available 

Environment 

mapping 

○ ○ ○  

Light Number No limitation 

（*7） 

Up to80 

（*7） 

Up to80  

（*7） 

*7: or lower than it depending on 

your video card 

Parallel Light ○ ○ ○  

Point Light ○ ○ ○  

Spotlight ○ ○ ○  

Reflection on floor ○ ○ ○  

Ray 

Tracing 

Reflection × × ○  

Refraction × × ○  

HDR&IBL VRAM 256MBor 

more 

recommended 

× ○ ○  

Luminance Self Luminance △ 

（*8） 

○ ○ *8: You can set it but no Bloom or 

Star effect. 

Anti- 

aliasing 

Hardware ○ ○ ○  

Without motion ○ ○ ○  

Create Image Export ○ ○ ○  
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2 Installation 
 

After installing Hayabusa 2.0, you can activate Hayabusa by licensing Hayabusa 2.0.  

Even if the previous versionHayabusa 1.0 was installed, you can install Hayabusa 2.0 without uninstalling Hayabusa 1.0. 

 

Here is how to install Hayabusa 2.0. 

■ Install Hayabusa 2.0 itself  

■ Rhinoceros Plugin 

■ DirectX 9.0 (Check DirectX version and install it if you need to update it. ) 

 

 

2.1 Install Hayabusa 
 

Here is how to installHayabusa 2.0. 

 

■ Log in with Administrator privileges, and close all 

applications. 

 

■ Insert Hayabusa 2.0CD to ＣＤ-ROM drive. 

 

■ Open Hayabusa 2.0 CD, run Setup.exe in Hayabusa 2.0 

Installer folder to start Setup wizard. Read message, then 

click Next 

 

■ Read Hayabusa user agreement, click Agree 

 

■ Specify a folder to install Hayabusa and click Install to start 

installation 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

■ When installation is completed, Setup completed message 

 appears. Read it and click OK 
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2.2 Software Structure 
If Hayabusa 2.0 is installed correctly, the following folders and files are created. 

 

2.2.1 Hayabusa 2.0 Folder 
The following folders and files are created in the folder where Hayabusa is installed （e.g. C: \Program Files\Hayabusa2.0). The 

file surrounded by red rectangle is Hayabusa's executable file. 

 

 

 

2.2.2 Rhino 4.0 Plugin folder 
Hayabusa is installed and the following files are created in Rhino4.0Plugin folder (e.g. C:\Program Files\Rhinoceros 4.0\Plug-ins） 

 

 Hayabusa.rhp Plugin which exports Rhino models to Hayabusa2.0 

 Hayabusa.tb Toolbar file to place Hayabusa.rhp on Rhino menu. 

 Hayabusa.tb.bak a backup file of Hayabusa.tb. This file is created when Hayabusa.rhp is loaded. 
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2.2.3 Rhino Menu 
When it is installed correctly, the following icon appears on Rhino menu bar. 

 

 
 

 

2.2.4 Troubleshooting 
If Hayabusa 2.0 is not created on the Rhino menu, do the following steps. 

 

■ When Hayabusa folder is not created in Rhino's Plug-in folder 

First, create Hayabusa folder under the Rhino's Plug-in folder. 

(Most of case , C:\Program Files\Rhinoceros 4.0\Plug-ins) 

You need to place Hayabusa.rhp and Haybusa.tb to this folder. 

 

When Haybusa is not correctly installed, Hayabusa.rhp and Haybusa.tb are located under Hayabusa’s Plug-ins\Hayabusa folder. 

(Most of case , C:\Program Files\Hayabusa2.0\Plug-ins\Hayabusa) 

Copy Hayabusa.rhp and Haybusa.tb to the Rhino’s Plug-ins folder. 
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■ Load Hayabusa.rhp 

Then start Rhino, open the Option menu to make sure if Hayabusa.rhp is in Plug-ins folder and install it. 

 
 

■ Create Hayabusa Icon menu 

Click Rhino's Tools menu > Toolbar layout and select Hayabusa in the Toolbars dialog.  

If Hayabusa is not found in the Toolbar collection files, open the Open toolbar collection dialog and select Hayabusa.tb to add to 

the Toolbar collection files, then select it in the Toolbar collection files.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hayabusa icon will appear in Rhino. 
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2.3 Set license 
 

Here is how to set the license. 

The license of Hayabusa 2.0 is a node lock license. You can use it only on the particular PC.  

For obtaining a license, refer to 2.4 Apply for license on the next page.  

A license is issued for the PC MAC address. 

Here are the steps how to set a license. 

 

■ Create a directory on the c: drive called “glic”.(C:\glic) 

    Copy the License file（.lic） to the directory. 

You can copy it to other folder, but in that case, you need to specify the folder where the license file is in when you use 

Hayabusa for the first time. 

 

■ Start Hayabusa 2.0 by clicking the shortcut on the desktop or from the Program menu.  

When you copy the license file in C:\glic, the license is obtained and Hayabusa is started. 

 

■ If you copy the license file to another folder other than C:\glic,  

the dialog shown to the right is opened when you start Hayabusa  

for the first time, select [Setting the license folder] and click [OK]. 

 

 

 

 

 

 

 

 

 

■ The Specify the license file dialog is open for you to specify the location of the license file. 

Specify the folder where you copied the license file,and click [OK]. 

 

 

 

■ When the license is certified, Hayabusa 2.0will start.  

You do not have to specify the location of the license file after the first time. 

 

 

■ If you copy the license file to another folder other than C:\glic, the place of the license file is memorized in the registry of 

PC. When you change the license file from the place to the different directory,delete the registry key below. 

When Hayabusa2.0 is started after it deletes it, the directory of the license file is specified again. 

 

HKEY_CURRENT_USER\Software\Graps\Glic\License\Hayabusa2.0\folder 
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2.4 Apply for license 
 

To get license file for Hayabusa, please contact local reseller. 

 

http://www.griffinds.jp/ contact/index.html 
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3 Basic operation 
 

3.1 Start Hayabusa 2.0  
 

There are two ways to start Hayabusa 2.0. 

 

3.1.1 Start fromHayabusaModeler(Rhinoceros 4.0) 
 

When Hayabusa is installed, with the following commands you can use the function of exporting to Hayabusa renderer as a 

Rhinoceros 4.0 plug-in. 

 

■ AC-Hayabusa  (icon left click) 

■ AC-HayabusaOption (icon right click) 

 

These commands can be performed by clicking Hayabusa icons which were placed on Rhino menu after installing. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

（※icon） 
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3.1.2 3.1.2 Parameter settings 
For detail information on each parameter, please see "5.1 Import Rhinoceros data" - "5.1.1 Export from Rhinoceros". 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.1.3 From Start menu 
■ When you click Start (Windows), the Start menu appears. 

■ Select Program > Graps > Hayabusa 2.0 

 

 

3.1.4 From Desktop short cut 
■ Double click the Hayabusa 2.0 short cut which is created when Hayabusa is installed. 

 

 

 

 

 

 

 

 

 

3.1.5 From Quick Start toolbar 
■ If you register Hayabusa 2.0 on the Quick Start toolbar, you can start Hayabusa 2.0 by just clicking the Hayabusa 2.0 icon on the 

Quick Start toolbar. 

You can register Hayabusa 2.0 on the Quick Start toolbar by dragging and droppingHayabusa 2.0icon to the Quick Start toolbar. 
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3.2 Exit 
You can end Hayabusa 2.0 by selecting File on the menu bar > Exit. 

You can also end Hayabusa 2.0 by clicking X (Close) in the top, right corner of the main window. 

If the file has not been saved, a message appears to ask if you want to save it.  

 

 

3.3 System checker 
When you start Hayabusa, The system requirement program (System checker) is started on the PC where Hayabusa is installed. 

Please note that the red marked items are not the hardware or software recommended in the system requirements, so they 

may cause problems on starting system or showing data.  

 

 

When you click the Solve problem button, nTtechnology,. inc. Support center web site opens. 

 

System checker runs when you use Hayabusa for the first time, but after that it is not started any more. 

If you want to check your PC's system environment again, start Hayabusa by selecting Start > Program > Rhinoceros 4.0 menu. 
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3.4 Window/Tab Operation  
 

<Window type> 

Main window 

This displays models. The menu bar and the toolbar are displayed at the top. 

 

Scene graph window 

This displays the model tree and the material tree. 

You can select data or edit models (objects)' structures. 

 

Setup window 

This is used to set up scenes. 

You can set materials, cameras, lights, backgrounds, projects and animations. 

 

Presentation window 

All functions you need for presentation are put together here. 

You can switch cameras, change colors, parts or backgrounds and control animations. 

 

Library window 

You can apply a material to the specified object by dragging and dropping it from the Material tab. 

You can also take a background or a light set in a scene by dragging and dropping it from the Background tab.  

 

Variation window 

You can switch and hide/show materials and parts.  

 

Action history window 

Displays the history that you have performed in Hayabusa 2.0 and you can undo and redo the operations. 

 

Conversion window 

You can move, rotate and scale objects by entering number. 

 

<Dock windows/tabs> 

■ You can freely move and dock each window to the top, bottom, right and left side of the screen by dragging the top grey title 

bar. (The presentation window can be docked only to the top and bottom of the main window.) 

■ The Docking guide appears when you drag a window to the top, bottom, right or left side of the screen. When you release 

dragging a window on the Docking guide, the window is docked to the side. If you do not want to dock a window to the side, 

drag it while pressing the Ctrl key. 

■ You can also dock a window by double clicking the Title bar or the tab. 

And you can release docking by double clicking the Title bar or the tab of the docked window. 

■ You can change the window to a tab by dragging the bar at the top of the window and dropping it to the other window. 

(Depending on the combination of the windows, some may not be changed to tabs.)  

■ When the window is changed to a tab, the tab appears at the top of the window, and you can switch windows by clicking the 

tab. The window changed to a tab can be switched back to a window by dragging the tab.  
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3.5 Mouse operation 
You can use your mouse to control cameras and lights and pick objects in Hayabusa 2.0. 

 

<Control camera> 

There are two kinds of modes for cameras, one is the Viewing mode where a camera is rotating around the target point, and the 

other is the Walkthrough mode where a camera is rotating or moving like walking in the 3D space. 

You can set a view mode to each camera individually. You can switch modes by selecting Setup> Camera, from the Presentation 

window and by pressing F7 key. 

Here is how a camera works in each mode.  

 

You can customize the mouse operations for controlling cameras. (See “3.7 Customize operations")  

 

【Viewing mode】 

 

Rotation： Pressing the right mouse button while moving the mouse right and left or up and down rotates the camera around the 

target point. 

 

 

 

 

 

 

 

 

 

Move：Pressing the Shift key and the right mouse button while moving the mouse right and left or up and down moves the camera 

parallel. 

 

 

 

 

 

 

 

 

 

Forward/Backward： Pressing the Ctrl key and the right mouse button while moving the mouse right and left or up and down 

moves the camera back and forth. With a scroll wheel mouse, you can move the camera back and forth by moving the wheel back 

and forth. 

 

 

 

 

 

 

 

 

 

①Up  

②

 

①

 

②Backward 

Camer

 

③Up 

④

 

②Right ①Left 

② ① 

④ 

③ 

Camera 

③Up  

④

  

②Right  ①Left  

② ① 

④ 

③ 

Camer
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【Walkthrough mode】 

 

Rotate： Pressing the left mouse button while moving the mouse right and left or up and down rotates the camera around 

itself. 

 

 

 

 

 

 

 

 

 

Move： Pressing the Shift key and the right mouse button while moving the mouse right and left or up and down moves the 

camera parallel. 

 

 

 

 

 

 

 

 

Forward/Backward： Pressing the Ctrl key and the right mouse button while moving the mouse up and down moves the camera 

back and forth. With a scroll wheel mouse, you can move the camera back and forth by moving the wheel back and forth.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

①Up 
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①
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Cam

 

Here is how a camera rotates in the Viewing mode and the Walkthrough mode.  

 

Rotation center = 
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<Select Object> 

 

To select an object, place the mouse pointer on the object that you want to select and double click it. 

By default, an object which is at the most front within the bounding box is selected, but if you double click again while pressing 

the Alt key, you can select another object behind the most front object.  

Also, if you double click another object while pressing the Shift key, you can add the clicked object to the selection while 

maintaining the current selection.  

When you click or press the Esc key in an area where no object is, the selection is released. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When an object is selected, the object is displayed in Shaded + Wireframe. (You can change the wire frame color displayed on 

selecting. To change the wireframe color, select Environment setup > Show tab > Wireframe color. 

Also, the selected objects are displayed as "Selected" in the Scene graph tree. 

The number of polygon and the tessellation info of the selected objects are displayed in the Object tab in the Setup window and 

the material info of materials attached to the selected objects is displayed in the Material tab.  

 

Select object 

 

Double click 

 

In order from the front  

Select the next object 

 

When selecting 

 

Double click 

 

＋ 

[Shift] ＋ 
Add to the selection while 

maintaining the current 

selection 

 

When selecting  

 

Double click  

 

[Alt] 
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3.6 Assign function to key 
 

Hayabusa 2.0 can control the following functions with using the keyboard short cuts. 

 

Keyboard short cuts 

Category Command Assign to key 

File Open Project Ctrl + O 

Save Project Ctrl + S 

Save Project As Ctrl +  

End Ctrl +  

Edit Undo Ctrl + Z  

Undo Ctrl + Y  

Show Show shadow Ctrl + K 

Camera Guide Alt + C 

Light Guide Alt + L 

Information Ctrl + I 

Wireframe Ctrl + W 

Show Still image with anti-aliasing Ctrl + Shift + 

Full screen Ctrl + F 

Window Show Presentation window Ctrl + P 

Move window F2 

Rotate window F3 

Scale window F4 

Coordinate System Local coordinate F12 

World coordinate F11 

Show view Save active Camera View F5 

Retrieve View F6 

Focus on the selected object  Ctrl + G 

Reset target point Ctrl + Shift + G 

Material Select material group Shift + Alt + Number 

Select material Ctrl + Shift + M 

Apply Material Ctrl + R 

Camera Switch Camera Ctrl + Number 

Background Change Background Ctrl + E 

Animation Stop animation（※） Alt + S 

Pause/restart animation（※） Alt + P 

Switch rendering modes Standard Renderer Ctrl + F1  

High Quality Renderer Ctrl + F2 

Real time renderer Ctrl + F3 

 

To customize, you can register key operations. 

To register functions, use the Customize function. (See the next section "3.7 Customize operations") 

 

※�Customizing is available only for the animations that are selected in the Animation tab (Setup window) or the Presentation 

window. 
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3.7 Customize operations 
 

You can customize menu bar items, keyboard operations and mouse operations in Hayabusa 2.0. 

To customize, select the menu bar Window > Customize and choose a tab which you want to customize in the Customize 

window. 
 

<Customize menu bar/toolbar > 

In the Command tab, you can add/remove icons and commands to/from the menu bar and the toolbar by dragging and dropping. 

 

Categories: Each category in the menu bar and all commands 

Commands: Command in each category  

Description: Descriptions of each command 

 

 

 

 

 

 

 

 

<Add/Remove icon to/from menu bar and toolbar> 

In the Commands column (D), select an icon (or command), which you want to add. 

■ With the left mouse button, drag and drop the selected command in the menu bar or the toolbar to add. 

■ When you want to delete an icon (or command), select it in the menu bar or the toolbar, and click Delete in the right 

click context menu. 

 

Toolbars: Toolbars and menu bars which are currently set  

Reset: Resets the changes which were selected in the 

Toolbars tab 

Reset All: Resets all changes 

New:  Sets newly 

Rename: Changes toolbar names 

Delete: Deletes the toolbars that you set. You cannot delete 

the toolbars which are set as defaults. 

 

 

 

 

<Keyboard short cut> 

You can assign a menu bar command function to a short cut key in the Keyboard tab. 

 

Category:  Each category in the menu 

bar(File/Edit/Function/Show/Window/Help) 

Commands: Shows commands in each category 

Current Keys:  Shows the keys which are set as defaults and the keys 

are already set. 

Press New Short 

Cut key: 

You can set a short cut key in the field. 

Assign: Press when you assign the short cut key that you set. 

Remove: Removes short cut keys that you set.  

Reset All: Reset all keys to the default settings. 
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<To add a keyboard short cut> 

Example： Set up a short cut for the command to export a background (Select File > Export > Background)  

 

■ In the Category column (C), select "File" and in the Commands 

column (D) select "FileExportBackground". 

 

 

 

 

 

 

 

 

 

 

 

■ In the Press New Shortcut Key field (N), press the Alt key and B as 

the ones you want to assign. "Alt+B" is displayed in the field. When 

you select "Alt+B" in the Current keys （U）, the Assign button 

appears. Press this button to set it as a short cut. 

 

 

 

 

 

 

 

 

 

■ If the short cut key that you want to assign has already been assigned, 

the assigned command name is displayed below the field and you 

cannot assign it.  

 

 

 

 

 

 

 

 

 

 

 

<To remove the assigned keyboard short cut> 

Example ：  Remove the short cut for the command to export a 

background (Select File > Export > Background)  

■ In the Category field (C) select "File" and in the Commands field (D) 

select "FileExportBackground".When you select "Alt+B" in the 

Current keys field (U), the Remove button is appears. Press this 

button to remove it.  
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<Customize other operations> 

You can register functions to the toolbar in the Menu tab. 

 

Show Menus for:  Shows the default menu 

Reset: Resets settings to the default status. 

Select context menu: You can set menus, which appear when clicking the right 

mouse button, by dragging and dropping to the toolbar.  

Reset:  Resets settings to the default status.  

 

 

 

 

 

 

 

 

In the Option tab, you can customize how to display the toolbar and the menu bar. 

 

Show Screen Tips on 

toolbars: 

When you place the mouse on the toolbar icon, the name of 

the tool is displayed. 

Show Shortcut keys in 

Screen tips: 

Shows the short cut key 

Menus Show recently 

used commands first:  

Shows the commands, which you don't use recently, 

depressed  

Show full menus after a 

short delay:  

The commands which were used recently are displayed first 

and all commands are displayed after a short delay. 

Reset my usage data: Reset settings to the default status. 
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4 Environment setup 
 

In the Environment setup dialog, you can set the PC environments and your preference items such as the rendering engine, the size of the 

posture and the time of jittering.  

 

When you select the menu bar Window > Environment setup, the Environment setup dialog appears. 

In the Environment setup dialog there are several tabs that you can switch. 

Some items require you to restart Hayabusa or reload the project file to set up.  

The settings are maintained and retrieved when you start Hayabusa the next time. 

 

4.1 Rendering quality 
 

This switches the rendering modes, the anti-aliasing ON/OFF and HDR modes. 

Rendering mode: This switches the rendering modes. 

■Standard Renderer  Rendering that uses the DirectX standard 

functions 

■High Quality Renderer  High quality rendering that uses a shader 

■Real time Ray Tracing  High quality rendering by the shader which 

simulates reflection and refraction accurately  

Hardware Anti-aliasing Hardware anti-aliasing is available .Depending on 

the video card, the HDR rendering Bloom effect 

may be invalid. 

Without motion 

Anti-aliasing: 

Anti-aliasing is performed when the camera is 

without motion .Displacing (jittering) a viewpoint 

position little by little randomly when there is no 

camera and no motion makes less jaggy.  

Jittering Quality: This specifies the number of jittering. The more 

the number is, the stronger the anti-aliasing 

without motion will be. 

The smallest jittering radius: This specifies the maximum radius for jittering. If 

you set this greater than 0.5, it gets blurrily. 

HDR/IBL: This specifies whether or not to do the 

HDR/IBL process. 

■Invalid: 

 This does not the HDR/IBL process. 

■Valid (without Bloom effect）: 

This does the HDR/IBL process, but not the 

Bloom process. 

■Valid (with Bloom effect）: 

This does both the HDR/IBL process and the 

Bloom process. 
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4.2 Real time ray tracing 
 

This sets the settings of the real time ray tracing. 

This is enabled only when the rendering mode is Real time ray tracing. 

 

In motion: Number of 

Reflection: 

This specifies the maximum number of the 

reflection calculation when the camera is 

moving. The reflection calculation by Real time 

ray tracing takes long time. A smaller value like 

1-2 is recommended for better response. 

If ray tracing is not completed within the 

specified number (reflection or refraction is still 

continued), the surface of the object is displayed 

in black. 

 Number of Refraction: This specifies the maximum number of the 

refraction calculation when the camera is 

moving. A smaller value like 1-2 is 

recommended for better response. 

If tracing is not completed within the specified 

number, the surface of the object is displayed in 

black. 

Without motion: Number of 

Reflection: 

This specifies the maximum number of the 

reflection calculation when the camera is not 

moving. 

If ray tracing is not completed within the 

specified number, the surface of the object is 

displayed in black. Setting the number about 10 

is recommended, because even if you set much 

higher number, the next process will start 

anyway when the tracing is completed.  

 Number of Refraction: This specifies the maximum number of the 

refraction calculation when the camera is not 

moving. 

If ray tracing is not completed within the 

specified number, the surface of the object is 

displayed in black. Setting the number about 10 

is recommended, because even if you set much 

higher number, the next process will start 

anyway when the tracing is completed. 

The smallest jittering radius This specifies the maximum radius for jittering. If 

you set this greater than 0.5, it gets blurry. 

HDR/IBL This specifies whether or not to do the 

HDR/IBL process.  

■Invalid: 

This does not the HDR/IBL process.  

■Valid (without Bloom effect）: 

This does the HDR/IBL process, but not the 

Bloom process. 

■Valid (without Bloom effect）: 

This does both the HDR/IBL process and the 

Bloom process.  
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4.3 Material Setup 
 

This sets how to display metallic materials. 

 

Show Metallic material: For Metallic materials, you can choose from two 

display methods, Standard and Older format 

(Hayabusa 1.0). 

The default is Standard. 

With Standard, when you see the object, which is 

attached a metallic material, from a distance, the 

metallic flakes disappear. With Older format, the 

metallic flakes always appear regardless of distance. 

 

 

 

 

4.4 Show 
 

This sets the wireframe color, the size of the posture and the color when the posture is selected.  

 

Wireframe color: This specifies the wireframe color to be shown when 

you select an object.  

Posture scale: This specifies the size of the posture. 

Selected Posture color: This specifies the color of the arrow or the circle 

which is selected when you are operating the 

posture. 

 

 

 

 

 

 

 

4.5 Coordinate 
 

This specifies the coordinate direction and units. 

The settings here are the defaults when the file is read, they are not applied to the current scene directly.  

If you want to change the settings for the current scene, select Setup > Project and change the values in the dialog.  

 

Coordinate System: This specifies the default coordinate direction for 

importing a new model. The direction that you set 

here becomes the default one, but you can change it 

in the option settings in the open file dialog before 

importing a model.  

Unit： This specifies the default unit for importing a new 

model. As with the default coordinate, you can 

change this before importing a model.  

Move scene to center: When this is selected and you import a new model, 

the model is moved to the center of the scene 

automatically.  
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4.6 View mode 
 

This sets the starting view mode (Viewing/Walkthrough).  

 

Viewing mode: This specifies the default coordinate direction for 

importing a new model . 

The direction that you set here becomes the default 

one, but you can change it in the Option settings in 

the Open file dialog before importing a model. 

Walkthrough mode: This specifies the default unit for importing a new 

model. As with the default coordinate, you can 

change this before importing a model.  

 

 

4.7 Library 
 

This specifies the default paths for the material libraries and the background libraries. 

 

Material:  This specifies the default path for the Material library 

window. 

Background: This specifies the default path for the Background 

library window. 

 

 

 

 

 

4.8 Conversion window 
 

This sets the units for Move and Scale. In the Conversion window, you can set the positions of objects, cameras and lights. 

 

Move: This sets a unit for the Move conversion window. 

You can choose from mm, cm, m and inch. 

Scale: This sets a unit for the Scale conversion window. 

You can choose from Percent and Decimal number. 

Associated with Posture: When this is selected, the Conversion dialog is 

opened associated with the posture. 
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4.9 3D Device 
 

Controlling cameras with 3D CONNEXION's SpaceNavigator is available.  

When you want to use SpaceNavigator, connect your PC and the SpaceBall. For further information on SpaceNavigator, refer to 

SpaceNavigator's documentations. 

 

Action: This defines the directions of moving and rotating 

operations. The action for CAD systems is 

opposite to one for CG systems. 

Move value: This sets the distance of the Move operation.  

Rotational value: This sets the quantum of the Rotate operation. 
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5 Import/Save files 
 

5.1 Import Rhinoceros data 
 

5.1.1 Export from Rhinoceros 

■ When you click Hayabusa button  in the Rhinoceros tool bar with the left mouse button, the data in the Rhino scene will be imported 

to Hayabusa.  

■ When you click Hayabusa button with the right mouse button, the Output setting dialog appears for you to set the output settings. 

Since the setting data is saved, you do not have to set them every time when you output a file. 

 

Material Type: Rendering: This exports the rendering color as a 

material. 

Layer: This exports the layer color as a material. 

Shading: This exports the shading color as a 

material. 

Object type: Polygon: This exports after dividing into 

polygons in Rhinoceros. 

NURBS: This exports to NURBS without dividing into 

polygons in Rhinoceros. 

Vertex weld: Select this when you want to export to polygons after welding the 

adjacent vertices. 

This is available only when you select Polygon as object type for exporting. 

This sets the Permissible range and the Smoothing angle. 

Export invisible layer Not export: This does not export the data in the 

invisible layers to Hayabusa. 

Export: This exports the data in the invisible 

layers to Hayabusa. 

Hayabusa  

Rendering Mode 

HDR: This starts Hayabusa in HDR mode. 

 

LDR: This starts Hayabusa in LDR mode. 

 

Show Option When this is selected and you click the Hayabusa button, the Export 

Option dialog appears. Then when you click the OK button, the data will be 

exported.  

Reload setting When this is selected and importing Rhinoceros data to Hayabusa, 

materials, backgrounds, lights and camera data in the scene will be 

reloaded.  

Wake-up setting When exporting data, the specified Hayabusa.exe is run. When you click 

the Edit button, the Open file dialog appears for you to specify a Hayabusa 

program to run.  

 

<Notes> 

■ Some errors may occur if you import the NURBS data, which was created with other CAD or 3D modeler programs, to Rhinoceros and output 

them to NURBS. 

In that case, you can avoid the error by outputting to Polygon when outputting the data from Rhinoceros. 
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5.2 Import project data 
 

Start Hayabusa 2.0. 

 

■ Select the menu bar File>Open Project. 

 

■ Specify a file (.hy2) to import. 

 

■ When you click Open, Hayabusa starts importing the file. 

The file is imported as it is when it was saved. 

 

■ If you want to import a backup file, select Hayabusa2 backupfiles as a file type. 

At this time, specify a backup file to import and the location to place the file. 

 

Do not develop: The file is saved to a temporary folder, not saved to a particular folder. 

The same folder: The file is saved to the same folder as its backup file.  

Specified folder The file is saved to the specified folder.  

When you select "Specified folder", the Reference button is enabled for you to specify a folder to create the file. 

 

 

<What is backup file?> 

When you select "Hayabusa backup file (hyp2_backup)" as a file type when saving the project file, not only does this save the model 

geometries, material data, lights, cameras and background data, but also the linked data such as mapping images and background images are 

saved together. This is helpful when you want to have the data in your notebook PC or backuplocation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Project file hyp2 

 

･Geometry data 

･Material data 

･Background data 

･Camera data 
･Light data 

Refer 

Mapping data Background image 
Refer 

Backup file hyp2_backup 
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5.3 Open Model 
 

Select the menu bar File > Open Model to import additional data or comparison models. 

 

Add  Adds a model to the current scene. 

Comparison model Imports models (or projects) for showing comparisons. 

 

 

5.3.1 Add 
 

This imports a model to the current scene additionally.  

 

■ When you select the menu bar File > Open Model > Add, the Open file dialog appears. 

 

■ Specify a project file to import（.hyp2, hyp2_backup）and click OK. The project file will be imported to the current scene additionally. The 

project file is displayed as a additional model in the Scene graph tree.  

 

5.3.2 omparison model 
 

This imports a current model and a model to be compared. 

 

■ When you select the menu bar File > Open Model > Comparison model, the Open file dialog appears. 

 

■ Specify a project file（.hyp2, hyp2_backup）to import and click OK. The project file is imported as a comparison model.  

 

■ For how to show comparison models, see the section "Presentation/Show Comparison". 

 

 

 

5.4 Open Hayabusa 1.0 project 
 

■ Select the menu bar File > Import >Hayabusa 1.0 project.  

 

■ Specify a file （.hyp） to import.  

 

■ When you click Open, Hayabusa starts importing the file. 
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5.5 Save data 
 

■ Select the menu bar File > Save Project As.  

 

■ Enter a file name（.hyp2）to save as. When you select "Hayabusa backup file (hyp2_backup)" as a file type, not only does this save the 

model geometries, material data, lights, cameras and background data, but also the linked data such as mapping images and background 

images are saved together. This is helpful when you want to have the data in your notebook PC or backup location. For information on 

backup files, see 5.2 "Import project data".  

 

■ Select one of the following three data types of saving and click Save. 

 

Save as Polygon&NURBS: This saves both data. Just after importing data, the saved polygon information is displayed. You can subdivide 

polygons after importing data, because NURBS is also saved. 

Save as NURBS: This saves data as NURBS. The polygon information displayed will be lost. 

Save as Polygon: Data is saved as a polygon. NURBS data will be lost, so the subdivision process cannot be performed after saving. 

 

 

5.6 File output 
 

You can export material, camera, light and background files by selecting the menu bar File > Export. The exported material files and background 

files can be used as a library. 

 

 

 

5.7 Import file 
 

You can import material, camera, light and background files and Hayabusa 1.0 project files （.hyp） by selecting the menu bar File > Import.  
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6 Setup 
 

After importing the model data from Rhinoceros you can set up materials, lights and backgrounds in Hayabusa to improve the model data's 

quality for display and rendering.  

 

6.1 Setup procedure 
Setting up is done mainly in the Setup window and the Library window. 

If you register materials and backgrounds which are used often, you can proceed the setup process effectively.  

 

The Setup window has seven tabs (Object, Material, Camera, Light, Background, Animation and Project). To open the Setup window, select the 

menu bar Window > Setup. To open the Mapping dialog to set mapping properties, click a mapping button in the Mapping section in the Material 

tab. 

 

The Library window has two tabs (Material and Background). You can drag and drop the data registered in the Library window to the scene.  

To open the Library window, select the menu bar Window > Library. 

 

Also, you can change the model structure and group models in the Scene graph window, and move, rotate and scale objects with using the 

Conversion window or the Conversion guide.  
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6.2 Scene graph 
 

In the Scene graph, you can show the scene structure, group models and edit the model structure. To open the Scene graph window, select 

the menu bar Window > Scene graph. The Scene graph has two trees (Scene tree and Material tree). 

You can do the following operations in each tree. 

<Scene tree> 

Change name: To change the name, click the name and edit it. 

Move group: You can move a group by dragging and dropping it. 

Switch Show ON/OFF:  You can switch ON/OFF by selecting/deselecting the check box.  

Group selected geometries： To group the selected object, select an object, click the right mouse 

button and select "Group selected geometries" from the right click 

context menu. 

Create New Group： From the right click context menu Create New Group creates a new 

group in the same level as the selected object.  

Remove： This removes the selected object. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

<Material tree> 

Change name： To change the name, click the name and edit it.  

Apply to object： To apply a material to the selected object, select an object, select a 

material, click the right mouse button and select "Apply to Object" 

from the right click context menu. 

Create New： When you select "Create New" from the right click context menu, 

the New material dialog appears. Enter a name and a type, and click 

the OK button to create a new material. 

Remove： From the right click context menu Remove removes the selected 

object. You cannot remove materials in use. 

Copy： From the right click context menu Copy copies the selected material. 

Select Object from Material： To select all objects which have the same material, select the 

material and select "Select Object from Material" from the right click 

context menu. 
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6.3 Set up project 
 

This sets a coordinate and a unit for the project you are working on. To open the Project tab, select the menu bar Window > Setup > Project.  

 

Select Scene: This specifies the registration address for a newly created 

item. 

Coordinate System: The coordinate system is displayed in Yup in Hayabusa 2.0. 

This sets based on the coordinate used when the data was 

created.  

If you created the data in Zup, Zup→Yup is set. If you created 

the data in Yup, Yup→Yup is set.  

Unit: This sets a unit for data. Select the same unit as you used 

when the model was created. To show models in absolute size 

correctly and to calculate the camera matching and the 

attenuation for point lights accurately, set the units correctly. 
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6.4 Set up object 
 

This determines if objects are shown or hidden and shadows are created or not. Also, this sets the accuracy of polygon subdivision for NURBS 

data.  

To open the Object tab, select the menu bar Window > Setup > Object.  

 

<Name> 

Name: This displays the name of the selected object. 

The name can be changed. You can also change it by clicking the 

name in the Model tab in the Scene graph.  

<Show> 

Show: When this is selected, the object is displayed. You can also 

show/hide an object by using the check box in the Scene graph 

Scene tab or Switch Show ON/OFF in the right click context 

menu. 

Cast: This specifies whether or not the selected object will create 

shadows.  

When it is selected, the object creates shadows. 

Dropped: This specifies whether or not the selected object will receive 

shadows from the other objects. When this is selected, this 

object receives shadows. 

<Subdivision> 

Number of polygons: The number of polygon of the selected object is displayed. When 

the object is polygon data, it is displayed in gray. 

Subdivision Simple setting 

button: 

【Rough】 

【Fine】 

When the selected object is NURBS data, you can change the 

subdivision number by clicking this button .If it's polygon data, 

you cannot do it. 

NURBS Subdivision Tolerance: Entering NURBS subdivision tolerance value and clicking Division 

button subdivides the polygon with the specified value. The 

smaller the value is, the smaller it will be .If it's polygon data, you 

cannot do it. 

Apply topological processing: When this is selected, the polygon is subdivided in relation to the 

phase (Topology) of the polygon vertices against the entire 

scene. When you press the Division button, the subdivision 

process will be started. 

This process may merge the adjacent vertices to represent the 

smoothness of the surface, but in some cases, depending on 

data, the polygon may be divided and result in an in unintended 

shape. In that case, divide it again without checking. 

Topology tolerance: When you want to perform a topological processing, set a 

tolerance for merging vertices. The greater the value is, the 

easier merging vertices will be, but depending on values or data, it 

may be divided in a different shape from the original. 

Use global settings: You can set ON/OFF for the NURBS subdivision tolerance and 

the Topology for each object. When this is selected, the polygon 

subdivision is performed with the conditions set above and the 

settings set individually on each object are ignored. (When the 

subdivision is performed with "Use global settings", the individual 

settings are cleared.) 

Division button: This subdivides NURBS data into polygons based on each 

setting value. 
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6.5 Move/Rotate/Scale operation 
 

With using the posture or the Conversion window, you can move objects, cameras and lights and scale objects. 

 

<How to use the posture> 

■ When you select an object and click the left mouse button on the toolbar Move, Rotate or Scale, the posture appears.  

 

 

 

■ You can move, rotate and scale the model by dragging the RGB arrow or the circle of the posture.  

 

 

■ You can change the posture position by switching the radio buttons in the Conversion dialog. If you choose "Center of object" and click "In 

select", the center of the posture is moved to the center of the currently selected object. If you click "Arbitrary selection", the pointer 

changes to a finger shape and the center of the posture is moved to the position where you clicked in the object.  

 

■ You can switch the conversion direction between World coordinate and Local coordinate in the pull-down menu in the toolbar. F11 key 

(World) and F12 key (Local) are also available to switch the conversion direction. However, you cannot scale in World coordinate. 

 

World coordinate: This operates move, rotate or scale along the scene orientation. Even if the 

target object has already been rotated, the coordinate system is not rotated 

and the object is converted along the coordinate orientation. 

Local coordinate: The orientation of the selected object. For example, If the object has already 

been rotated, the object is converted along the coordinate orientation placed 

after rotation. 

 

 

■ If you select "Associated with Posture" in the Conversion dialog (Environment setup > Conversion window), you can associate the 

Conversion dialog with the posture to display.  

■ You can change the posture position by switching the radio buttons in the Conversion dialog. If you choose "Center of object" and click "In 

select", the center of the posture is moved to the center of the currently selected object. If you click "Arbitrary selection", the pointer 

changes to a finger shape and the center of the posture is moved to the position where you clicked in the object.  

 

<How to use the Conversion dialog> 

■ When you select an object and right click the toolbar Move, Rotate or Scale, the posture appears. 

■ Enter values in the Absolute field or the Offset field to convert. 

■ If you select "Associated with Posture" in the Conversion dialog (Environment setup > Conversion window), you can associate the 

Conversion dialog with the posture to display.  

Move button Rotate button Scale button 

Move posture Rotate posture Scale posture 

 

Specify the posture center 
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6.6 Material Setup 
 

Hayabusa 2.0 defines a model's texture by setting materials on objects. 

These are the methods to set materials. Depending on the purpose, you can set materials effectively by using a particular method. 

 

 

6.6.1 Setup in Material tab 
 

To open the Material tab, select the menu bar Window > Setup > Material 

 

■ Select a material in the Scene graph tree or the Material list. 

■ When you click the material tab in the Setup window, the material tab appears and shows the information of the selected material. 

 

<Material list> 

Material list The materials imported to the scene are listed. To change the name, 

click the name and edit it.  

New button: This creates a new material. When you click the button, the New 

Material dialog appears .Enter name and type, then click the OK 

button to add a material. 

You can also add a new material by selecting Window > Scene graph > 

Material and right click anywhere in the material tab and select create 

new. 

Copy button: To copy a material, click the Copy button while selecting the material.  

Remove button: To remove a material, click the Remove button while selecting the 

material. You cannot remove the material in use. 

You can also remove a material by selecting Window > Scene graph > 

Material and right click anywhere in the Material tab and select 

remove. 

Apply new: The following is the steps to assign material. 

1. select an object 

2. Select a material in the list in the Material tab or the Scene graph 

Material tab. 

3. Click the Apply New button 

（You can also remove materials by using the Short cut Ctrl+R） 

 

 

 

Operation Invoke Purpose Target object 

Material Setup tab Setup window/Material To set material's details All objects that are applied the same 

material as the selected object's. 

Material library Material library window To apply a material from the Material 

library to the current scene. 

All objects that are applied the same 

material as the dropped object's. 

Eyedropper 

 

Right click context menu/Eyedropper  To extract only the necessary data from 

the material and apply it to the other. 

All objects that are applied the same 

material as the selected object's.  
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<Name&Type> 

Name: The name of the selected material is displayed. The name can be 

changed. 

Type: These are the following six material types in Hayabusa. 

Set a type depending on the material. 

Lambert Appropriate for simulating the materials which do not reflect lights 

like rubber 

This only uses diffuse reflection based on the reflection rule that 

incoming lights diffuse evenly in all directions. 

Phong Appropriate for simulating plastic 

This diffuses components and mirror components separately for 

light ray, sight line and normal vector. 

Blinn Appropriate for simulating metal 

This calculates diffuse light and reflection light components in 

relation to diffusion and direction of the model in addition to light 

rays, sight lines and normal vectors. 

Clearcoat Appropriate for simulating clearcoat paint 

The surrounding environment is reflected by using Blinn + 

Clearcoat. 

Glass Appropriate for simulating glass or transparent plastic 

The surrounding environment is reflected based on Phong. 

Metallic Appropriate for simulating metallic paint 

The surrounding environment is reflected by using flake paint + 

Clearcoat. 

 

 

Editable items for each type: Part 1 

 Diffuse 

color 

Environment 

color 

Reflection 

color 

Opacity Mapping Environment 

 reflection 

Shadow 

Drop Texture Bump Specular 

Lambert ○ ○ × ○ ○ ○ × × ○ 

Phong ○ ○ ○ ○ ○ ○ ○ × ○ 

Blinn ○ ○ ○ ○ ○ ○ ○ × ○ 

Clear coat ○ ○ ○ ○ ○ ○ ○ ○ ○ 

Glass ○ ○ ○ ○ ○ ○ ○ ○ ○ 

Metallic ○ ○ ○ ○ ○ ○ ○ ○ ○ 

 

 

Editable items for each type: part 2  

 
Highlight 

Sharpness 
Highlight size 

Highlight 

Strength 

Clear coat 

Index 
Scale Bias 

Reflection 

Roughness 

Lambert × × × × × × × 

Phong ○ × × × × × × 

Blinn × ○ ○ × × × × 

Clear coat × ○ ○ ○ ○ ○ ○ 

Glass ○ × × ○ ○ ○ ○ 

Metallic ○ × × ○ ○ ○ ○ 
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<Color setting> 

Diffuse color: This sets diffuse reflection color. It becomes the basic color of the 

material. 

It is influenced by parallel light, point light and spotlight. 

Environment color: Unlike the direct reflection of light, this sets the color of the light 

reflected by the environment. It is influenced by environment light. 

Reflection color: This sets the mirror reflection color. It becomes the color of 

highlights. 

It is influenced by parallel light, point light and spotlight.  

Self luminance color: This sets the color of self emitting light. 

An example of this is the color of LED lights. 

Opacity The greater the value is, the more opaque it will be. The value of 0 

results in completely transparency. 

 

 

 

■ If you click a color sample, the color editor shown as below appears. Set a color by 

moving the graduation slider or entering RGB or HSV value. 

■ If you click the Color Picker button in the Color editor, the eyedropper icon appears, 

then you can sample any colors you want in the screen with the icon while holding 

the left mouse button. 

 

 

 

 

 

 

 

 

■ When you click the Color palette button, the Color palette appears for you to select 

a color. 
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6.6.2 Setup in Material library 
 

You can assign a material in an object by dragging and dropping the library registered material to the object.  

When you select the menu bar Window > Library or the toolbar Library, the Library window appears. 

 

Default： When you click the Default button, the maker moves to the 

default folder. To set the default folder, select the menu bar 

environment setup > library. 

Specify Folder area: This specifies a material folder which contains material files. 

Material files in the folder are displayed in the file list. 

Material file list： All material files （.hmt2）in the selected folder are listed. If you 

select a material file here, the material data is displayed in the 

Material data list. 

Material data list: Material data in the selected material file is displayed as thumbnail. 

 

 

<How to export Material library data> 

If you select the menu bar File > Export > Material, you can export all materials in the scene as a material file (.hmt2).  

You can use the material files as library data as they are. 

 

<Manage library> 

In the area where the library data is displayed, you can cut, copy, paste, delete or rename by using the right click context menu. 

To paste, do the following procedure. 

 

■ Select material data and select Copy or Cut 

■ Specify a material file to paste 

■ Click Paste in the right click context menu. 

  

 You can also select Rename or New in the right click context menu in the Material file list. 

 

<Apply to scene> 

Select a material and drag & drop on the object in the scene. At this time, the material is applied to the all objects which are assigned the same 

material of the object that you dropped. In the Scene graph Model tab (not 3D view) you can also drag & drop a material in the group or the 

object. 

After selecting an object, you can assign a material by selecting a material and selecting the right click context menu Apply to scene. 

It is useful for assigning a material only to certain objects. 

 

<Apply only mapping data> 

You can apply only mapping data by dragging & dropping a material while pressing the Alt key .When you drop the data in the scene while 

pressing the Alt key, the Apply Mapping dialog appears. If you select mapping data to apply and click the OK button, you can assign the 

specified mapping data only. 
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6.6.3 Eyedropper function 
 

You can extract an arbitrary data from the selected material and apply it to the other materials. 

 

<Register eyedropper> 

This extracts a particular data of the material. 

When you select Register Eyedropper in the right click context menu while selecting a 

material, the Register Eyedropper dialog appears. After making sure items that you want 

to extract, click Register. 

 

<Apply eyedropper> 

When you select Apply eyedropper in the right click context menu while selecting an 

object, the Apply eyedropper dialog appears. After making sure items that you want to 

apply, click Apply, the material parameter is applied to the object that is registered the 

eyedropper. 
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6.7 Setup texture 
 

Hayabusa supports three kinds of mapping such as Textures, Bumps and Specular. You can add texture easily by using images for mapping. 

You can superimpose textures, bumps and specular to maps. Hayabusa supports five types of mapping format such as Plane, Cylinder, Sphere, 

Triplanar and UV. 

 

 

6.7.1 Texture Mapping 
 

This pastes an image as a pattern of the material. To set a texture map, click the Texture mapping button in the Material tab (Setup > Material) 

to open the Mapping dialog. First, specify an image with the Image button in the Image setting section (the default is None), and adjust the 

mapping settings. 

 

Operation: This is only available for texture mapping. 

You can choose from Multiplication, Decal and Stencil. 

If you want to paste with decal or stencil, set alpha to the texture. 

For decal, depending on the alpha value, the color of the base 

material will be blended. For stencil, this makes it transparent 

according to the alpha value. 

Image setting: If you click the button, the Open file dialog appears for you to specify 

a mapping image. To change the image, click this button as well. 

An extremely large image will use a lot of your computer's video 

memory. Depending on your video card, up to 2048 x 2048 is 

recommended. 

Remove: This removes images. 

Display image: The window opens for you to see the image. 

Image direction: This reverses UV. 

Reset Reverse: This resets the reverse to restore the initial status. 

How to paste: Select one from Plane, Cylinder, Sphere, Triplanar or UV. 

・Plane This maps as if projecting to a plane. 

・Cylinder This maps as if projecting to a cylinder. 

・Sphere This maps as if projecting to a sphere. 

・Triplanar This map in the x, y or z axis or whichever is closest 

to the normal. 

・UV This maps along the  UV direction of NURBS.  

Show guide: This shows a guide of how to paste depending on the options you 

choose. 

Move: When you click this with the left mouse button, the translation 

posture appears .Drag the posture to move the mapping. If you 

click this with the right mouse button, the translation dialog appears 

for you to specify the translation amount in number. 

Rotation: When you click this with the left mouse button, the rotation posture 

appears. Drag the posture to move the mapping. If you click this 

with the right mouse button, the rotation dialog appears for you to 

specify rotation amount in number. 

Scale: When you click this with the left mouse button, the scale posture 

appears. Drag the posture to adjust the scale. If you click this with 

the right mouse button, the scale dialog appears for you to specify 

scale value. 

Size category: There are two kinds: Relative and Absolute .If you select Absolute, 

this maps a specified size according to the unit setting. If you select 

Relative, the size of the boundary box which contains objects with 

the mapped material will be 1.The greater you set, the bigger it maps 

and if you set it smaller than 1, the image is mapped repeatedly. 

(When Repeat is enabled） 
Move mapping posuture example 
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Specify W/H: This specifies the width and the height of mapping in number. The 

greater you set, the bigger it maps. 

Rest 

Move/Rotate/Scale/Size： 

This restores the initial settings of Move, Rotate, Scale or Size. 

Repeat: If you turn Repeat off, Hayabusa does not map the same image 

repeatedly even if the size is smaller than 1.  

Initial direction of axis: Specify the mapping axis direction. 

Mapping reference: You can map with the same settings as other mapping's by the 

Mapping reference. This is used to match mappings perfectly when 

you want to use the same image for texture and bump. 

 

 

6.7.2 Bump Mapping 
Bump mapping uses images to simulate bumps. You can simulate bumps on the model surface or engraved letters easily. You can set a bump 

in the Mapping dialog. To open the Mapping dialog, select Setup > Material tab and click the Bump button in the Mapping section.  

 

First, specify an image with the Image button in the Image setting section (the default is None), and adjust the mapping settings.  

Set the mapping by the same procedure as Texture mapping's. You can change the depth of the bump by changing the bump scale. 

 

6.7.3 Specular Mapping 
Specular Mapping uses images to simulate colors and patterns in the gloss area. This is used to simulate the fine gloss of materials. You can 

set a bump in the Mapping dialog. To open the Mapping dialog, select Setup > Material tab and click the Bump button in the Mapping section.  

 

First, specify an image with the Image button in the Image setting section (the default is None), and adjust the mapping settings.  

Set the mapping by the same procedure as Texture mapping's.  

 

6.7.4 Customize Environment mapping 
You can set environment data to reflect on Clear coat, Glass and Metallic materials individually. 

Set this by the following procedure.  

 

■ When you click the Customize Environment map in the Mapping section in the 

Material tab (Setup > Material), the Open file dialog appears for you to specify an 

environment map image. Specify an image then click Open. 

■ Click the Adjust button next to the Custom adjust button in the Mapping section in 

the Material tab (Setup > Material). 

 

 

 

 

 

 

■ Adjust reflection with X, Y, Z slider. If you click the Guide button, the posture appears. 

You can adjust the posture by dragging it. 

 

 

 

 

 

 

 

■ If you want to release the Custom environment map, click the Release custom environment map button in the dialog (Setup > Material > 

Mapping section > Customize Environment map button).  

 

Rotate mapping posuture example 
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Camera guide display example 

Camera Guide 

Target point 

6.8 Camera setup 
 

You can create a camera which has an arbitrary position, orientation and view angle. There is no limit in the number.  

To open the Camera tab, select Window > Setup > Camera. 

When you select a camera in the Camera list, the information of the selected camera is displayed. 

 

<Camera list> 

Camera list: The cameras imported to the scene are listed. To change the name, 

click the name and edit it.  

To switch the cameras, select/deselect the check box. 

New button: This creates a new camera. When you click the button, the New 

Camera dialog appears. Entering a name and clicking the OK button 

will create a camera. 

Copy button: To copy a camera, click the Copy button while selecting the camera.  

Remove button: To remove a camera, click the Remove button while selecting the 

camera. You cannot remove the camera in use. 

 

<Project&View Angle> 

Projection method: This selects the method of projection. Perspective projection uses 

perspective. Parallel projection does not use perspective. 

View angle: Specify a camera view angle (Vertical View/Horizontal View) .If you 

make the view angle bigger, the image may look more perspective like 

looking through a wide angle lens. If you make it smaller, the image 

may look less perspective like looking through a telephoto lens. 

Standard value setting: This sets the view angle equal to the focal distance of a 35mm film 

camera lens. 

Mode: This sets view mode. There are two kinds of view modes, one is the 

Viewing mode where the camera is rotating around the target point, 

and the other is the Walkthrough mode where the camera is rotating 

or moving like walking in the 3D space. You can switch between these 

two modes with the F7 key. 

Perpendicular axis fix: When this check box is selected and you move the camera with the 

mouse, the Roll angle is always set to 0.Therefore, the horizontal line 

does not bend. This fixes to Perpendicular axis as the default.  

 

<Adjust camera's position> 

When you select the camera and left click the toolbar Move or Rotate, the conversion 

guide appears. You can adjust the guide by dragging it with the mouse. When you right 

click the toolbar Move or Rotate, the conversion window appears. You can adjust 

numerically. 

The camera guide can be shown by pressing Alt+C. 

 

 

 

 

 

 

<Save/Retrieve Camera View> 

If you select "Save current view" from the right click context menu, the position, orientation and view angle of the current camera are saved 

and become as the default for the next time when you switch the camera. You can also get the position and orientation of the current camera 

back to the default by selecting "Retrieve view" from the right click context menu. 
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6.9 Setup light 
 

You can set a light in the arbitrary position and orientation of the scene. 

You can set up to 80 lights. To open the Camera tab, select the menu bar Window > Setup > Camera.  

When you select a light in the Light list, the information of the selected light is displayed. 

 

<light list> 

Light list: The lights imported to the scene are listed. To change the name, 

click the name and edit it.  

You can switch turning the light ON/OFF by 

selecting/deselecting the check box.  

New button:  This creates a new light. When you click this, the New Light 

dialog appears. Enter a name and click the OK button to add a 

light. 

Copy button:  To copy a light, click the Copy button while selecting the light.  

Remove button:  To remove a light, click the Remove button while selecting the 

light. You cannot remove the light in use. 

<Type> 

Type: There are three kinds of light.  

 ■Parallel light 

A light source which emits lights unidirectionally. .Shadows can 

be created from this light. 

■Point light 

A light source which emits lights in all directions from a single 

point. Attenuation can be set. Shadows cannot be created from 

this light. 

■Spotlight 

This is a point light, but you can set the irradiation angle and the 

outline blur. Shadows can be created from this light. There is 

another light that is Environment light, but this is set in the 

Background tab. 

Expansion: This option provides the expansion type for lights. You can select 

either normal or minus light .Normal light makes things look 

lighter when it illuminates. Minus light makes things look darker 

when it illuminates. Minus lights are suitable when you want to 

make a particular area darker.  

<Light color setting> 

Light color: When you click a color sample, the color editor appears for you 

to set a light color by moving graduation slider or entering RGB 

or HSV value. 

<Shadow setting> 

Cast shadow: When this is selected, shadows are calculated. It is available only 

for the Parallel light and the Spotlight. However, if the rendering 

mode is set to standard, the shadow calculation is not performed. 

Apply self shadow: When this is selected, shadows are cast on the model itself and 

not only cast on the floor. 

Shadow darkness: The grater the value you enter, the darker the shadow will be. 

Soft shadow: The edge of the shadow is blurred when the camera is not 

moving. if the value is 0, blurring is not performed. The higher the 

value is, the bigger the blur will be. This process is performed with 

jittering .If you want to blur widely, select the menu bar 

Environment setup > Rendering quality tab and set more than 

128 in the jittering quality. 
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Light guide display example 

Spotlight guide Point Light guide 

Parallel Light guide 

<Attenuation setup> 

Attenuation type: It is available to set attenuation for point lights and spotlights. 

You can select either from None/Linear/Quadratic. If you 

choose None, the attenuation calculation for point lights is not 

performed. For Linear, the attenuation is proportional to the 

distance. For Quadratic, it is proportional to the square of the 

distance.  

Attenuation distance: When you select Linear or Quadratic as the attenuation type, set 

a distance from the light where the attenuation calculation starts. 

<Spotlight> 

Spot size: This adjusts the size of the irradiation area for the spotlight. The 

higher the value is, the bigger the irradiation area will be. 

Shading off size: The higher the value is, the bigger the edge blur in irradiation area 

will be. 

 

 

 

<Adjust light's position> 

When you select the camera and left click the toolbar Move or Rotate, 

the conversion guide appears. You can adjust the guide by dragging it 

with the mouse. When you right click the toolbar Move or Rotate, the 

conversion window appears. You can adjust numerically.  

The light guide can be shown by pressing Alt+L. 

 

 

 

 

 

 

 

 

 

 

 

 

 

<Number of lights that create shadows> 

Hayabusa 2.0 can calculate shadows for up to 24 lights. However, the shadow calculation may significantly reduce performance. Also, if your 

video card performance is low or your video memory is small, only a few shadows can be calculated.  

 

<Solar position calculation> 

With the Solar position calculation, you can calculate the solar position by using a parallel light to resemble the sun. 

For information on the Solar position calculation, see “15.5 Solar position calculation". 
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6.10 Set background scene  
 

You can set more than one background. There is no limit in the number of backgrounds. Backgrounds are associated with lights, so when you 

switch the background, the light is automatically switched to the corresponding one.  

 

6.10.1 Setup in Background tab 
 

To open the Background tab, select the menu bar Window > Setup > Background. When you select a background in the Background list, the 

information of the selected background is displayed. 

 

<Background list> 

Background list: The backgrounds imported to the scene are listed. To change the name, click 

the name and edit it.  

To switch the backgrounds, select/deselect the check box.  

New button:  This creates a new background. When you click the button, the New 

Background dialog appears. Entering a name and clicking the OK button will 

create a background.  

Copy button:  To copy a background, click the Copy button while selecting the background.  

Remove button:  To remove a background, click the Remove button while selecting the 

background. You cannot remove the background in use. 

<Background property> 

Size: This sets the size of a background. When you click the Automatic button, it 

updates the size of the background automatically. 

Geometry: This specifies how to display the background. You can choose either of 

cube/sphere/dome. 

Single color: Select this when you want to display the background in a single color. After 

selecting the radio button, specify a background color to display. When you 

click a color sample, the color editor appears for you to set a color for the 

background by moving graduation slider or entering RGB or HSV value. 

Import image button: If you click the button, the Open file dialog appears to specify a background 

image. The specified image will be used for the background reflecting the 

clear coat, metallic or glass materials. Also, when you select the Background 

radio button, the image is displayed as a background in the scene. 

Background textures use 360 degree all-sky image. Use either format of 

Cube (dds), Sphere or Light Probe. 

If you use non all-sky image, the reflection may look unnatural and the image 

may look distorted when displayed as a background, as well. 

 If you use a HDR image as a background texture, the reflection looks natural 

with high contrast, and you can use effects such as Bloom and Star for HDR 

images to represent high luminance materials. When you use a HDR image, 

select the menu bar Environment setup > Rendering quality tab and enable 

HDR. Note that you must have a higher performance video card than a 

regular one to enable HDR. 

2DBackground image: 

 

This specifies 2D background image to be the background for the model .If 

you click the None button set by default, the Open file dialog appears, from 

where you can specify an image. The specified image will be used as a 

background like wall paper. It will not be a part of the reflection calculation. If 

you select Background texture as display method, the image is displayed in 

the background. To delete it, click the Remove button. You need to adjust 

the image to match the camera position so as not to look unnatural, since a 

2D image is not an all-sky image. With the Camera matching function, you 

can combine a 2D background image and the model naturally. 

Gamma correction: This corrects the gamma of 2D background images. The greater the value 

you enter, the weaker the contrast will be and vice versa. 
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Exposure correction: This performs exposure correction for 2D background images. The greater 

the value you enter, the brighter it will be and vice versa. 

<floor> 

Show floor: When this is selected, the floor is displayed. 

Display shadow: When this is selected, shadows are displayed on the floor. 

Floor height: This sets the height of the floor .If you make the value greater, the floor 

position gets higher. 

Single color: Select this when you want to display the floor in a single color. 

Floor image: Select this when you want to map images to the floor. 

Floor color: This specifies the floor color. If a single color is specified for the floor color, 

the floor is displayed in the specified color.  If you want to display textures 

on the floor, the textures are also blended with the specified color. 

Specify image button If you click the button with the floor texture name, the open file dialog 

appears for you to specify a floor texture image. 

Shading: Select this, if you want the floor is influenced by lights (calculate shading), 

select this. included) 

Floor reflection: This reflects a model on the floor. The higher the value is, the stronger 

reflection will be. 

Floor roughness: This adjusts how rough the reflection on the floor will look. The grater the 

value is, the more the reflection blurs. As it processes with jittering, when the 

camera is not in motion, the reflection on the floor has a gradual blur. 

<Environment color setting> 

Environment light color: This sets the intensity and the color of environment light. The Environment 

Light color affects only the environment color of materials. 

<HDR setup> 

Bloom: This simulates bright lights. The smaller the value you enter, the bigger bloom 

will be. 

Star: This displays star shaped glare for strong lights. The greater the value you 

enter, the bigger the glare will be. When it's0, there will be no glare. 

Gamma: This sets a gamma value on rendering. The greater the value you enter, the 

weaker the contrast will be and vice versa. 

Exposure: This sets an exposure value on rendering. The greater value you enter, the 

brighter it will be. The smaller the value you enter, the darker it will be. 

Light: This sets the brightness of lights. Adjusting this value affects the brightness 

of all lights used in the scene. 

Diffuse environment light: This calculates diffuse environment lights from the background data and 

renders them. The greater the value you enter, the more the diffuse 

environment light will affect. 

Gamma correction: This corrects the gamma of 2D background images. The greater the value 

you enter, the weaker the contrast will be and vice versa. 

Exposure correction: This performs exposure correction for 2D background images. The greater 

the value you enter, the brighter it will be and vice versa. 

<floor> 

Show floor: When this is selected, the floor is displayed. 

Display shadow: When this is selected, shadows are displayed on the floor. 

Floor height: This sets the height of the floor .If you make the value greater, the floor 

position gets higher. 

Single color: Select this when you want to display the floor in a single color. 

Floor image: Select this when you want to map images to the floor. 

Floor color: This specifies the floor color. If a single color is specified for the floor color, 

the floor is displayed in the specified color.  If you want to display textures 

on the floor, the textures are also blended with the specified color. 

Specify image button If you click the button with the floor texture name, the open file dialog 

appears for you to specify a floor texture image. 
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Cube light probe sphere 

Shading: Select this, if you want the floor is influenced by lights (calculate shading), 

select this. included) 

Floor reflection: This reflects a model on the floor. The higher the value is, the stronger 

reflection will be. 

Floor roughness: This adjusts how rough the reflection on the floor will look. The grater the 

value is, the more the reflection blurs. As it processes with jittering, when the 

camera is not in motion, the reflection on the floor has a gradual blur. 

<Environment color setting> 

Environment light color: This sets the intensity and the color of environment light. The Environment 

Light color affects only the environment color of materials. 

<HDR setup> 

Bloom: This simulates bright lights. The smaller the value you enter, the bigger bloom 

will be. 

Star: This displays star shaped glare for strong lights. The greater the value you 

enter, the bigger the glare will be. When it's0, there will be no glare. 

Gamma: This sets a gamma value on rendering. The greater the value you enter, the 

weaker the contrast will be and vice versa. 

Exposure: This sets an exposure value on rendering. The greater value you enter, the 

brighter it will be. The smaller the value you enter, the darker it will be. 

Light: This sets the brightness of lights. Adjusting this value affects the brightness 

of all lights used in the scene. 

Diffuse environment light: This calculates diffuse environment lights from the background data and 

renders them. The greater the value you enter, the more the diffuse 

environment light will affect. 

 

 

 

 

 

 

 

 

 

 

6.10.2 Setup in Backgrond library 
 

You can set a background easily by dragging & dropping a library-registered background file in the scene.  

When you select the menu bar Window > Library or the toolbar Library, the Library window appears. 

 

Default: When you click the Default button, the maker moves to the 

default folder. To set the default folder, select the menu bar 

Environment setup > Library. 

Show background file area: Background files （.hbg2）in the selected folder are listed.  

 

 

 

 

<How to export material library data> 

Select the menu bar File > Export > Background, all backgrounds in the scene are exported as background files （.hbg2）.  

You can use the background files as library data. 

 

<Apply to Scene> 

When you select a background and drag & drop it in the scene, the background and the related light information are imported in the scene.  
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Create new animation 

6.11 Animation setup 
 

If you set key frames in an animation, you can switch object motions, camera motions, materials, parts and backgrounds in the animation.  

You can do real time viewing and export an animation as a movie as well.  

To open the Animation tab, select the menu bar Window > Setup > Animation. 

The Timeline window appears in conjunction with the Animation tab. 

 

<Animation creation process> 

 

■ Click New in the Animation tab to create a new animation. 

 

■ Select the created animation. 

 

■ Set the time in the Timeline window. Click the Update button in the Create frame to 

register the key frame .If there is a selected object when you click the button, the object 

is registered as a motion object. Also, if you select "Register Camera Info" in the 

Timeline window, the current camera is registered as a camera motion key. 

 

■ When you select the key ▼, the information of the key is displayed in the Animation tab. 

Set an animation to the key where you can switch parts or backgrounds as required.  

 

■ Set the animation length in the Timeline window. When you start the animation, it is 

played in the time that you set with or without frames. 

 

■ Set a short cut for starting the animation or Repeat as required.  

 

■ Check how to work the animation with using the Control buttons in the Timeline window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

<Play animation> 

 

■ If you set a particular object as a starting animation object, when you click the object with holding the Alt key, the animation starts. When the 

mouse pointer is placed on the particular object, the shape of the pointer becomes a finger shape. 

 

■ With the following short cuts, you can stop or pause the animation. 

 ・Alt+S :Stop 

 ・Alt+P :Pause (animation starts again from this point when pressing Alt+P once again.)  

However, it is available only for animations selected in the Animation tab (Setup > Animation) or in the list in the Presentation window. 

 

■ If the Repeat is selected, the animation is repeated.  

Create key frame/Update button 
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<Animation list> 

List: The animations imported to the scene are listed. To change the name, click the 

name and edit it.  

New button:  This creates a new animation. When you click the button, the New Animation 

dialog appears. Enter name and type, then click the OK button to add an 

animation. 

Copy button:  To copy an animation, click the Copy button while selecting the animation. The 

registered key frames also can be copied. 

Remove button:  To remove an animation, click the Remove button while selecting the animation.  

<Key frame> 

Name: Name of the selected frame is displayed. 

Time: Time of the selected frame is displayed. You can change the time here. You 

cannot change the time in the timeline. 

Move object: Object motions and camera motions are interpolated with curve 

(spline).However, if there is no change between frames, curve interpolation is 

cut at that point. For example, when you define frames like F1→F2→F3→F4

→F5→F6 and register the exact same positions and poses for F3 and F4, 

interpolation is cut between F4 and F5.Using this method, you can set an 

animation in linear motion by registering frames as the same position and the 

pose intentionally. 

 You can register only one moving object (or group) for each frame. 

If you want to move several objects together, you need to group them first or 

define them in a different frame. 

Move camera: Select this, when you want to control the camera. Camera data is registered or 

updated when you click the Register/Update key frame button in the Timeline. 

View angle info is not maintained. 

Switch Materials: When this is selected, materials are switched in the frame. Specify a 

replacement material after switching in the list box. The material groups and the 

material are combined and displayed in the list box. To set a material group or a 

material , select Variation > Material tab. 

Switch parts: When this is selected, parts are switched in this frame. Specify a replacement 

part after switching in the list box. The part groups and the part are combined 

and displayed in the list box. To set a part group or a part, select Variation > 

Part tab. 

Change Background When this is selected, backgrounds are switched in this frame. Specify a 

replacement material after switching in the list box. 

<Animation control> 

Starting object: When this is selected and you click the specified object (or group), the 

animation starts. After selecting this when you select an object and press the 

Update button, the object is registered .If you place the mouse pointer on a 

starting object, the mouse pointer icon turns to a finger shape, so you can tell 

that the animation is set on the object. The animation starts when you click 

with holding the Alt key. If you click the starting object when an animation is 

done, the animation starts to play in reverse. 

Short Cut Key: When this is selected, if you press the specified key, the animation starts. If you 

set the same key to several animations, when you press the short cut key, all 

animations start at the same time If you press a short cut key when an 

animation is done, the animation starts to play in reverse. 

Repeat: When this is selected, Hayabusa repeats playing the animation. To stop the 

animation, click the Stop button on the Timeline or press the short cut key. 
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7 Variation 
 

If you group materials or parts and associate them with an object, you can switch materials or parts with one-click. 

You can setup the variation in the Variation window. To open the variation window, select the menu bar Window > Variation or the toolbar 

Variation. 

 

7.1 Setup material variation 
 

In the Material tab in the Variation window, specify in which object you change the material and a material to be applied. 

 

Create material group: When you click the New button, a "New Group" is added to 

the list. You can change the name of the group by 

highlighting it and clicking on it again. 

 

Remove material group: Select a material group in the list and click the Remove 

button, the material group is removed. 

Add (Remove) object: Here is the procedure to add an object.  

◆Select an object on the 3D view or the Scene graph. 

◆When you click the Add Object button, the Object list 

appears. 

◆When you highlight an object in the list and click the Add 

selected button, the selected object is added to the Object 

list. 

  

To remove the object, select it in the list and click the 

Remove from list button. 

In some cases, it may be hard to determine the object by 

the name in the list .In those cases, select the object in 

the3D view first, then click the Remove selected button. 

Add material: Here is the procedure to add a material. 

◆ When you click the Add Material button, the Material 

group member list appears. 

◆ This specifies materials to be displayed in the list. 

Show selected materials -->Display only currently selected 

materials in the scene. 

Show all materials --> Display all materials registered in the 

scene.  

◆ Select a material to be registered from the materials in 

the list and click the OK button. 

That's all for the process to register a material. Registered 

materials are displayed in the material list. To open the 

Material list, select Variation > Material tab.  

Change material: When you double click a material in the Material list 

(Variation > Material tab), the material for the specified 

object is switched.  

 

<Example: Switch the wristwatch dials by changing the material. > 
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7.2 Setup parts variation 
 

In the Part tab in the Variation window, specify a part and an object.  

 

Create part group: When you click the New button, a "New Group" is added to 

the list. You can change the name of the group by highlighting 

it and clicking on it again。  

Remove part group: Select a part group in the list and click the Remove button, the 

part group is removed. 

Add part: When you click the New button, a "New Group" is added to 

the list. You can change the name of the group by highlighting 

it and clicking on it again.  

Remove part: Select a part and click the Remove button, the part is 

removed. 

Add object: Here is the procedure to add an object to the part.  

◆ First, select an object in the 3D view or the Scene graph 

to add.  

◆ Select a part in the Part list.  

◆When you click the Add object button, the Object list 

appears.  

◆ When you highlight an object in the Object list and click the 

Add selected button, the selected object is added to the 

object list.  

To remove the object, select it in the list and click the Remove 

from list button.  

In some cases, it may be hard to determine the object by the 

name in the list. In those cases, select the object in the3D 

view first, then click the Remove selected button. 

Add "Not to show" to list: If this is selected, "Not to show" is added to the list. When you 

double click "Not to show", all objects in this part group are 

hidden.  

<Example> 

In the case that the group contains Part A-C, and you add 

"Not to show" to the list 

1. Part A --> Shows the objects belong to AB and C are not 

displayed. 

2. Part B --> Shows the objects belong to BC and A are not 

displayed. 

3. Part C --> Shows the objects belong to CA and B are not 

displayed. 

4. Not to show --> does not show neither A, B nor C. 
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8 Reload 
 

After editing data in Rhinoceros and exporting it back to Hayabusa, Hayabusa 2.0automatically reloads materials, backgrounds and lights that 

are used in the current scene.(*) 

(*)For materials, Hayabusa reloads them based on the IDs that are exported for each object from Rhinoceros, so if an ID is changed, Hayabusa 

cannot reload the material of the ID.  

 

As above, Hayabusa automatically reloads the data when they are exported from Rhinoceros to Hayabusa, you can reload them manually too.  

To reload manually, do the following steps. 

 

■ When you select the menu bar Function > Reload, the Reload dialog appears.  

 

 

 

 

 

 

 

 

 

 

■ When you click the File selection button after selecting "External file" as a reference 

data, the Open file dialog appears. 

 

■ To load Specify a Hayabusa project file （hyp2）and Click the Open button.  

 

 

 

 

 

 

 

 

■ In the Reload dialog, select Material, Background, Camera check boxes to make them files to be reloaded. 

 

■ When you click the OK button, the reload process starts and the specified data will be imported to the scene.  

You can switch the imported background and camera data by selecting them in the Background list or the Camera list. 
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9 Presentation 
 

The Presentation window has all switch functions required for presentation and seven tabs such as Camera, Material, Part, Background, 

Animation, Rotational motion and Show Comparison. To open the Presentation window, select the menu bar Window > Presentation.You can 

also show/hide the window with Ctrl+P. 

 

9.1 Switch camera 
 

Arrow buttons: You can switch to the regular position cameras (front/back/right/left/up/down) by clicking the left arrow button. 

List area: Cameras created in the Camera tab (Setup > Camera) are displayed as thumbnails. When you click a thumbnail, the current camera is 

switched to the clicked one. 

Triangle buttons: If you click either of the triangle arrows on the right and left of the title, the panel is switched. Here, you can change the view mode 

(Viewing/Walkthrough) and the project type (Perspective/Parallel) and fix the Perpendicular axis. 

 

 

 

 

 

 

 

 

9.2 Switch material 
 

Select group: Select a material group created in the Select group box in 

Material tab (Variation > Material tab) to list material 

members.  

List area: When you click a material thumbnail, the material is 

switched. 

 

 

 

9.3 Switch part 
 

Select group: Select a part group created in the Part tab (Variation > 

Part tab) to list part members.  

List area:  When you click a thumbnail, the part is switched. 

 

 

 

9.4 Switch background 
 

List area:  Backgrounds created in the Background tab (Setup > 

Background) are displayed as thumbnails. When you click 

a thumbnail, the background is switched. 

 

 

Switch material by click 

Switch part by click 

Switch background by click 

Switch camera by click Switch panel Switch panel 
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9.5 Play animation 
 

List area:  Animations created in the Animation tab (Setup > 

Animation) are displayed as thumbnails. Click to select 

an animation. 

Control buttons: You can play and stop the animation and jump to the 

beginning, end, previous frame or next frame. Operate 

after selecting an animation in the list. 

 

 

9.6 Play rotational motion 
 

Arrow buttons: You can play a turntable animation or camera animation 

by click the arrow button. 

To pause the animation, click the Pause button. 

Detail: If you click the detail button, the dialog is opened, from 

where you can change each rotation speed. 

 

 

9.7 Show Comparison 
 

Here is the procedure to show comparison. 

 

■ Select the menu bar File > Open Model > Comparison model to import a model to be compared. When the model is imported, the file name 

of the model is displayed in the list in the Show Comparison in the Presentation window. 

 

■ Specify how to divide the screen. 

 

■ When you drag & drop the comparison model from the list to the divided window in the 3D view, the comparison model is displayed in the 

specified window. 

 

■ If you double click in the window while the window shows the comparison, the window is magnified. When you double click the window again, 

you return to the comparison.  

 

■ If you want to remove the comparison model, click the Remove button. However, you cannot remove a model which is 

currently used for showing comparison.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Drag & Drop Specify how to divide the 

 

Select animation by click 
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10 Create Image 
 

With Hayabusa 2.0, you can create snapshots and movie files easily and quickly. You can export in the higher resolution than the display 

resolution. You can render with the real time renderer and the offline renderer 3DsmartRender (option)as well. 

 

10.1 Snapshot 
 

Hayabusa exports still images in the camera angle displayed in the 3D view. 

Export from the Create Image dialog. To open the Create Image dialog, select the menu bar Function > Create Image. 

 

When you click the Start button after setting up the following parameters, the Save As dialog shows up. When you click the Start button after 

specifying a file name, file type and quality, Hayabusa starts the process. 

 

Jittering quality: Hayabusa superimposes CG more than once by displacing a 

viewpoint position little by little randomly to make the 

curves less jaggy (Jittering). Here, you can specify how 

many times to repeat the jittering process .If you select 

offline in the rendering type, jittering is disabled.(For the 

Offline rendering, define the rendering quality with the 

Number of Sampling.) 

Pixel size: This specifies a pixel size for rendering. You can specify this 

regardless of the display resolution of your monitor. 

Pixel size Standard value setting: This specifies the pixel size with the standard value. 

Size: This specifies a paper size. Hayabusa calculates the pixel 

size from size x resolution. 

Size Standard value setting: This specifies the pixel size with the standard value. 

Resolution: his specifies the resolution in DPI (dots per inch). Hayabusa 

calculates the pixel size from size x resolution. 

Fix aspect ratio: When this is selected, the aspect ratio is fixed. 

Rendering type: 

 

Selects a renderer. Select either Real time or Offline by 

clicking the radio button. The Offline render is an option 

feature. You cannot select it if the license is not set. For 

further information on Offline renderer, refer to the section 

"Offline rendering". 

Setup 3DsmartRender: This is enabled when you select the Offline renderer .If you 

click the button, the 3DsmartRenderer setting dialog 

appears. 

 

 

<Export after applying transparency to background> 

If you want to export to PNG or TIFF, you can export after making the background transparent by selecting "Apply transparency to 

Background". When you export a file to PNG after applying transparency to the background and open the file in Photoshop, the background is 

displayed with transparency. If you want to export with a transparent floor as well, turn the Show Floor off in the Background tab.  

 

<Limitation> 

With the real time renderer, you can export in up to 12,000 x 12,000 pixel size. The resolution limitations vary depending on your computer's 

video memory. If you want to export an image with big pixels, divide the screen vertically and horizontally and render it in the small rectangle 

unit. If you use Bloom or Star, you might see the border lines of the rectangle. In that case, give Bloom the greater value and set 0 for Star to 

make the border lines less noticeable.  
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10.2 Camera at once 
 

Choose one from the registered cameras and export still images at once. Export from the Create Image dialog. To open the Create Image 

dialog, select the menu bar Function > Create Image. 

 

■ Select a camera to export images in the Camera list. 

 

■ As with the snapshot, specify the pixel size, rendering type and so on. 

 

 

 

 

 

 

 

 

■ When you click the Start button, the Save As dialog appears. Set a folder name, file 

name, format, file type and quality. 

 

■ When you click the Start button, Hayabusa starts the process. 

 

 

 

 

 

 

 

10.3 Fixed Camera 
 

Export still images in six directions such as Front & Back, Right & Left, and Up & Down to the model. Export from the Create Image dialog. To 

open the Create Image dialog, select the menu bar Function > Create image. 

 

■ Check a camera or cameras to export images in the Camera list. 

 

■ As with snapshot, specify a pixel size, rendering type and so on. 

 

■ When you click the Start button, the Save As dialog appears. Set a folder name, file 

name, format, file type and quality.  

 

■ When you click the Start button, Hayabusa starts the process.  
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10.4 Turntable 
 

This exports a movie (AVI or sequence number files) which rotates in 360 degree in one minute. Export from the Create Image dialog. To open 

the Create Image dialog, select the menu bar Function > Create Image. 

 

Jittering quality: Hayabusa superimposes CG more than once by 

displacing a viewpoint position little by little randomly to 

make the curves less jaggy (Jittering). Here, you can 

specify how many times to repeat the jittering process. 

If you select offline in the rendering type, jittering is 

disabled. 

Pixel size: This specifies a pixel size for rendering. You can specify 

this regardless of the display resolution of your 

monitor. 

Pixel size  Standard value 

setting: 

This specifies the pixel size from the list to render with 

the standard value setting. 

Fix aspect ratio: Select this when you want to specify the number of 

pixels by fixing the aspect ratio. 

Rendering type: Selects a renderer. Select either Real time or Offline by 

clicking the radio button. The offline render is an option 

feature. You cannot select it if the license is not set.  

For further information on Offline renderer, refer to the 

section "Offline rendering".  

Setup 3DsmartRender: 

(*Paid option) 

This is enabled when you select the offline renderer. 

If you click the button, the 3DsmartRenderer setting 

dialog appears. 

Frame rate: This specifies the number of frames per one second. 

Export type: This specifies either between outputting to AVI or 

outputting an incremental file. 

Start button: When you click the Start button, the Save As dialog 

appears. When you specify a file name and folder name 

and click the start button, the process is started. 

 

 

When you click the Start button after setting up parameters from above, the Save As dialog appears. When you click the Start button after 

specifying a file name, file type and quality, Hayabusa starts the process. 
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10.5 Camera Motion 
 

This exports a movie (AVI or sequence number files) which rotates around the model in 360 degree in one minute. Export from the Create 

Image dialog. To open the Create Image dialog, select the menu bar Function > Create Image. 

 

■ As with the Turntable, specify a pixel size, frame rate and so on. 

 

■ When you click the Start button, the Save As dialog appears .Set a folder name, file 

name, format, file type and quality. 

 

■ When you click the Start button, Hayabusa starts the process.  

 

 

 

 

10.6 Animation 
 

Choose one from the registered animations and export a movie (AVI or sequence number files). Export from the Create Image dialog. To open 

the Create Image dialog, select the menu bar Function > Create Image. 

 

■ Select an animation to export the movie in the Animation List. 

 

■ As with the Turntable, specify a pixel size, frame rate and so on. 

 

■ When you click the Start button, the Save As dialog appears. Set a folder name, file 

name, format, file type and quality.  

 

■ When you click the Start button, Hayabusa starts the process.  
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11 HDR Rendering 
 

You can simulate realistic textures by rendering in the HDR （High Dynamic Range） mode because of the natural contrast and the effect from 

Bloom and Star for the high brightness. Also, you can do the lighting calculation from background images in the IBL （Image Based Lighting） 

mode. 

 

 

11.1 Switch to HDR mode 
 

You can enable the HDR in the Rendering quality tab. To open the Rendering quality tab, select the menu bar Window > Environment setup.  

 

Valid (without Bloom effect）： This does the HDR/IBL process, but not the Bloom process. 

Valid (with Bloom effect）：This does both the HDR/IBL process and the Bloom process. 

 

HDR rendering is only available with a 32 bit floating decimal point video card (NVIDIA/Geforce 6800 GT, Quadro FX 3400 or later).  

HDR rendering uses more video memory than the regular rendering does. Use a video card which has 256MB or more video memory.  

 

 

11.2 Processing in HDR/IBL mode 
 

You can get the following effects in the HDR mode and the IBL mode. 

 

◆ To make shading and contrast natural  （HDR） 

◆ The exposure can be adjusted.  （HDR） 

◆ To simulate glare  （HDR） 

◆ Lighting calculation from background images is available. （IBL） 

 

You can set HDR parameters in the Background tab. 

Bloom: This simulates bright lights.  

Star: This displays star shaped glare for strong lights. 

Gamma: This sets the Gamma value to adjust the contrast for 

rendering. 

Exposure: This adjusts the exposure. 

Light: This scales the local lights. 

Diffuse environment light: This calculates the diffuse environment light from the 

background data. 

 

 

 

You can set IBL parameters in the Material tab. 

Effect to environment color: This calculates lights for the material's environment color. 

Effect to reflection color: This calculates lights for the material's reflection color. 

Highlight spread: This adjusts the highlight spread. 

Contrast of highlight: This adjusts the contrast of highlight. 
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12 Real time ray tracing 
 

Ray tracing is a rendering method that casts a sight line from the view point to every pixel of the display and renders in relation to light 

reflection and transparency on 3D models. It can represent objects realistically as it traces light paths emitted from a light source accurately 

according to reflections, refractions or transparency, however, since the calculation amount is enormous, it usually needs a very long time for 

the calculation. Hayabusa 2.0 uses your computer's GPU （Graphics Processing Unit: semiconductor chip for 3D drawing equipped on a video 

card), not your computer's CPU, to perform the real time ray tracing.  

 

In the Ray tracing mode, image files, movie files and Flash images are exported to ray tracing images.  

 

Rendering comparison 1 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rendering comparison 2 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

12.1 Switch to Real time ray tracing mode 
 

Select the rendering mode "Real time ray tracing (Real time ray tracing + Shader)" in the Rendering quality tab. To open the Rendering quality 

tab, select the menu bar Window > Environment setup. You can also switch to the Real time ray tracing mode with using the short cut Ctrl+F3. 

 

Without Real time ray tracing With Real time ray tracing 

Without Real time ray tracing With Real time ray tracing 
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12.2 Limitations 
 

<Supported video card> 

Hayabusa 2.0's processing speed highly depends on GPU performance, as Hayabusa's real time ray tracing is performed by GPU equipped on 

your video card (not CPU). Also, enough video memory is required. When you use ray tracing mode, you must use it under the following 

environment. It may be able to work in the insufficient environment, but you cannot expect enough performance of it and it may work 

unsteadily. 

 

   Requirements 

Video card：  NVIDIA Geforce8800 or higher 

Video memory： 512MB or higher 

Video driver： Strongly recommended to use the latest one 

 

<Drawing speed> 

In the Ray tracing mode, the rendering time is proportional to the rendering area (vertical pixel numbers by horizontal pixel numbers). If the 

rendering is slow and your editing work is not productive, it would be better to make the rendering area (the 3D screen area) smaller. 

 

<Preprocessing> 

When you switch to the Ray tracing mode or move an object (including animation), there will be some delay until the ray tracing image is 

displayed since Hayabusa does the preprocessing for real time display. Time required to perform the preprocessing depends on the complexity 

of the model or the scene.  

 

<Refraction calculation> 

Accurate calculation is performed only on models created in relation to thickness same as real world. If the model was created without 

considering of thickness or has a hole on the plane, the refraction calculation won't be accurate. Or if it was created in relation to thickness but 

the object connected to it has different refraction rate, you need to define it as separate model. 

The followings are requirements to perform accurate refraction calculation. 

 

Requirements to perform accurate refraction calculation  

■ Create a model considering the thickness and the refraction rate difference, between adjacent objects.  

■ If adjacent objects have different refraction rates, explode the model so that you can apply different materials to objects. 

■ When you set up a material, set its refraction rate and the adjacent objects' refraction rates correctly.  

 

Example: In the image below, the different color plane has to be created as a different model so that you can apply a different material on it.  

 

 

 

 

 

 

 

 

 

 

 

 

<Refracted image noise> 

For the complicated shape models or when reflection and refraction are repeated because of the view point position even if the model shape is 

simple, some noise may occur. The higher the refraction rate is, the more the noise occurs .If you are concerned about the noise when 

exporting an image, export it in high resolution because high resolution makes the noise less noticeable relatively.  

 

When the Real time ray tracing mode is selected, Hayabusa performs the attenuation calculation on transparent materials according to the 

distance. The attenuation here is the one that a ray which passes through gets color depending on the material's diffuse color. The attenuation 

(absorption) factor increases in proportion to the opacity. The attenuation is not considered in the other rendering modes, so the degree of 

transparency is different from one in the ray tracing mode. 

Refraction rate：1.8 

Adjacent refraction rate: 

  

 
Transparent container (Refraction rate:1.8） which has some liquid 

(Refraction rate:1.2） 

Refraction rate：1.8 

Adjacent refraction rate 

   

 

Refraction rate：1.2 

Adjacent refraction 

  

 

Refraction rate：1.8 

Adjacent refraction rate: 

  

 

Liquid 
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13 Automatic adjustment/ 
Tone mapping 

 

When you select adjust exposure automatically or tone mapping, images are displayed without over exposure or under exposure in 

consideration of the entire screen brightness. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.1 Auto-exposure 
 

This simulates a pupil by determining appropriate exposure from the entire screen brightness. Hayabusa uses the same algorithm as the 

camera's auto exposure. Auto-exposure and tone mapping are set in the Background tab in the Setup dialog. You can set it for each 

background, not each project.  

Adjust exposure automatically: When this is selected, Hayabusa performs the auto-exposure 

calculation. 

Correction value: If you set this positive, it will be over exposure (brighter) and if 

negative, it will be under exposure (darker).The brightness 

becomes two times higher (correction value. 

 

To perform the auto exposure calculation correctly, the HDR mode must be turned on. 

Adjust the brightness with the Correction value as required. 

 

 

13.2 Tone mapping 
 

The Tone mapping gets the maximum luminance in the scene and protects images from over exposure. The Tone mapping is available only 

when the Auto-exposure is turned on.  

Tone map: When this is selected, Hayabusa performs the tone mapping. 

Maximum  

luminance magnification: 

You can change the maximum luminance (white point) to 

adjust the contrast of the image. If you set the Maximum 

Luminance magnification smaller than 1, the Maximum 

Luminance will get low and all the luminance higher than it will 

have over exposure. 

If you set the Maximum Luminance magnification greater than 

1, the Maximum Luminance will get high and the area that had 

over exposure will get darker.  

 

To perform the tone mapping correctly, the HDR mode must be turned on. 

 

Example Auto-exposure OFF, Tone mapping OFF Example Auto-exposure ON, Tone mapping ON 
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14 Other functions 
 

 

14.1 Show absolute size 
 

With the Show absolute size function, you can display models in the absolute size in addition to displaying them according to the size of display 

device like a screen or the observation position. 

 

Here is the procedure to show the absolute size. 

 

■ Define a unit to be used in the scene in the project tab. to open the project tab, 

select setup > project. Set a unit used to create the model.  

 

■ Select the menu bar Function > Show absolute size to open the Show absolute size 

dialog.  

 

■ Set a height from bottom to top of a display device like a screen.  

 

■ Set a height from the floor to the bottom of the screen.  

 

■ Set a distance from the screen to the observation point.  

 

■ This sets the height of the view point.  

 

■ When the Move Camera in front of object is selected, the camera location is displayed in front of either of X,Y or Z axis direction (the 

closest one to current direction) when calculating.  

 

■ When you click the Calculation button, the model is displayed in absolute size. While the image is displayed in the absolute size, the screen is 

opened in full size automatically. To release the Full screen, close the Show absolute size dialog or press the short cut Ctrl+F. 

 

 

14.2 Move scene to center  
 

When you select the menu bar Edit > Move scene to center, the model is moved to make the center of current scene to be center of the floor 

and make the scene to be above the floor.  

When you select the menu bar Environment setup > Coordinate and select Move Scene to center, this process is performed automatically 

when you import a model.  

 

 

14.3 Fit to selected object  
 

If you select the Fit to selected Object from the right click context menu while selecting an object in the 3D view or the Scene graph, the 

camera is moved to the place where it can see the selected object at the front. 
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14.4 Camera matching 
 

With the Camera matching function, you can create composite images from 2D images taken with a digital camera and CG created in 

Hayabusa. If the camera locations of the 2D image and CG image are not matched, the composite image will look unnatural. Hayabusa uses the 

camera matching calculation to create a natural looking composite image. 

 

14.4.1 Create camera matching image 
 

For camera matching, the following two requirements must be met. 

 

◆ Requirement 1   You should know the lens perpendicular view angle (can be 

calculated from focal distance) of the camera used to take the image. 

◆ There should be a known rectangle size taken in the 2D image. 

 

Here is the procedure how to do camera matching. 

 

■ Set the right unit for the model in the Project tab. To open the Project tab, select Setup 

> Project. 

 

■ Select a 2D background in the Background tab (Setup > Background). When you specify 

a background, the selected image is displayed as a background. There should be a size 

known rectangle taken in this image. 

 

■ In the Camera tab (Setup > Camera), match the camera view angle with the one that was 

used when the 2D background was taken.  

 

■ Select the menu bar Function > Camera matching to open the Camera matching dialog. 

 

■ Specify the Size of maker in the Camera matching dialog. Enter height and width of the 

rectangle marker (Right image ①). 

 

■ Next, Click the Start marker point button (Right image ②) and click the screen to 

create the 1st, 2nd, 3rd and 4th vertices for the rectangle. You can get vertex data by 

placing the mouse pointer on any vertices and clicking the left mouse button. Enter 

values for Point 1 to 4 in order. To redo entering, click the Clear marker button to clear 

data and enter values for Point 1 to 4 again.  

 

■ When you click the Calculate Camera location button (Right image ③), the calculation 

starts and the camera will be moved to make the origin of the scene be displayed in the center of the marker. Since Hayabusa uses the 

method that repeats calculations to make tolerance smaller, you can save time by moving a camera to the location where you think it is 

appropriate before starting the calculation.  
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■ You can set Calculation tolerance and Calculation time. The calculation finishes when the result becomes within the specified calculation 

tolerance or the specified calculation time is over.  

■ To stop the calculation, press the Esc key.  

■ When you want to modify how to show a model after the calculation, move the model not the camera.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

14.4.2 Camera lens and Perpendicular view angle 
 

Camera lens and the corresponding Perpendicular view angle 

Lens focal distance Perpendicular view angle 

35mmCamera Digital single-lens 

camera 

16mm 10.5mm 74degree 

18mm 12mm 67degree 

20mm 13mm 62degree 

24mm 16mm 53degree 

26mm 17mm 50degree 

28mm 18mm 46degree 

30mm 20mm 44degree 

32mm 21mm 41degree 

34mm 23mm 39degree 

36mm 24mm  37degree 

38mm 25mm 35degree 

40mm 27mm 33degree 

42mm 28mm 32degree 

44mm 29mm 31degree 

46mm 31mm 29degree 

48mm 32mm 28degree 

50mm 33mm 27degree 

52mm 35mm 26degree 

54mm 36mm 25degree 

56mm 37mm 24degree 

58mm 38mm 23degree 

62mm 41mm 22degree 

66mm 44mm 21degree 

70mm 47mm 19degree 

74mm 49mm 18degree 

78mm 52mm 17degree 

82mm 55mm 17degree 

86mm 57mm 16degree 

Calculate Camera location button 

Model is moved onto the marker 

④ 

Pick 4 vertex of the marker 

③ 

② 
① 
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14.5 Solar position calculation 
 

With the solar position calculation, you can calculate the solar position based on latitude, longitude and time with using the parallel light as sun.  

You can choose the Southern direction from the four directions (X, -X, Y and -Y) in the Hayabusa 2.0Solar position calculation. Adjust the 

Southern direction by rotating the model as required. 

 

Here is the procedure to calculate the solar position.  

 

■ Select a parallel type light in the Light list. Or open the light guide and select a 

parallel light.  

 

■ When you select the menu bar function > solar position calculation, the solar 

position calculation dialog appears.  

 

■ Specify date, time, latitude, longitude and the southern direction in the dialog.  

  For Time, specify time in Japan time (UTC+9). 

  The slider can be used to change the Time.  

 If you specify a registered location name in the preset, you can set the location's 

latitude and longitude to the calculation.  

 

■ If you click the calculation button, the selected light direction is changed to fit the 

specified value.  

 

■ If you select the Automatic calculation check box, the light direction is automatically changed when you set each value. 
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15 Contact 
 

 

If you have any questions, please contact us with the following phone number or E-mail address.  

We will consider your opinions for future development to make it more productive for you 

 

For sales questions, contact Griffin Design Systems Co., Ltd. (Distributer).  

For technical questions, contact GRAPS Co.,Ltd. (Developer). 

 

Distributed by 

Griffin Design Systems Co., Ltd. 

〒150-0031 BEVERLY HILLS 203 Sakuragaoka-tyo Shibuya-ku Tokyo Japan 

TEL 03-5456-2680 FAX 03-5456-2681 

E-mail info@griffinds.jp 

 

 

 

Developed by 

GRAPS Co.,Ltd. 

 

〒150-0031 BEVERLY HILLS 203 Sakuragaoka-tyo Shibuya-ku Tokyo Japan 

TEL 03-5456-2680 FAX 03-5456-2681 

E-mail Hayabusa@graps.co.jp 

 

Supporting on the phone is limited to regarding installation.  

For technical questions other than regarding installation, please contact us with E-mail.  

Business hours: 10:00 AM -5:00 PM 

 

 

 

 

 

 

 

Data contributed by: Mr. Jiro Katayama, Tetsutaro Design, AppliCraft Co. Ltd., solidThinking Japan and Mr. Higuchi in STYLING3D. 

This software uses the FreeImage open source image library. See http://freeimage.sourceforge.net for details. 

FreeImage is used under the FIPL, version 1.0. 
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